[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Cannot compile matplotlib on FC8: error: pygtk/pygtk.h: No such file or directory



Greetings,

I'm trying to build and install matplotlib on Fedora 8, x86_64.
Compilation files as below, even if I have installed all the -devel
packages I could think of (namely pygtk2-devel. gtk2-devel...) and
explicitly set PKG_CONFIG_PATH to /usr/lib/pkgconfig . What else am I
missing? What else must I do to make the build script see pygtk.h,
which is at:

[root polaris matplotlib-0.98.0]# rpm -ql pygtk2-devel | grep 'pygtk.h'
/usr/include/pygtk-2.0/pygtk/pygtk.h
/usr/include/pygtk-2.0/pygtk/pygtk.h

TIA,
		Marco F.

[root polaris matplotlib-0.98.0]# make clean
`which python` setup.py clean;\
        rm -f *.png *.ps *.eps *.svg *.jpg *.pdf
============================================================================
BUILDING MATPLOTLIB
            matplotlib: 0.98.0
                python: 2.5.1 (r251:54863, Oct 30 2007, 13:45:26)  [GCC
                        4.1.2 20070925 (Red Hat 4.1.2-33)]
              platform: linux2

REQUIRED DEPENDENCIES
                 numpy: 1.1.0
             freetype2: 9.16.3

OPTIONAL BACKEND DEPENDENCIES
                libpng: 1.2.29
               Tkinter: no
                        * Using default library and include directories for
                        * Tcl and Tk because a Tk window failed to open.
                        * You may need to define DISPLAY for Tk to work so
                        * that setup can determine where your libraries are
                        * located. Tkinter present, but header files are not
                        * found. You may need to install development
                        * packages.
              wxPython: no
                        * wxPython not found
                  Gtk+: gtk+: 2.12.5, glib: 2.14.6, pygtk: 2.12.0,
                        pygobject: 2.14.0
                        * Could not find Gtk+ headers in any of
                        * '/usr/local/include', '/usr/include', '.'
                    Qt: no
                   Qt4: no
                 Cairo: 1.4.12

OPTIONAL DATE/TIMEZONE DEPENDENCIES
              datetime: present, version unknown
              dateutil: matplotlib will provide
                  pytz: matplotlib will provide

OPTIONAL USETEX DEPENDENCIES
                dvipng: 1.5
           ghostscript: 8.61
                 latex: 3.141592

EXPERIMENTAL CONFIG PACKAGE DEPENDENCIES
             configobj: matplotlib will provide
      enthought.traits: matplotlib will provide

[Edit setup.cfg to suppress the above messages]
============================================================================
running clean
removing 'build/temp.linux-x86_64-2.5' (and everything under it)
find . -name "_tmp*.py" | xargs rm -f;\
        find . \( -name "*~" -o -name "*.pyc" \) | xargs rm -f;\
        find unit \( -name "*.png" -o -name "*.ps"  -o -name "*.pdf" -o -name "*.eps" \) | xargs rm -f
find: unit: No such file or directory
find . \( -name "#*" -o -name ".#*" -o -name ".*~" -o -name "*~" \) | xargs rm -f
[root polaris matplotlib-0.98.0]# python setup.py build
============================================================================
BUILDING MATPLOTLIB
            matplotlib: 0.98.0
                python: 2.5.1 (r251:54863, Oct 30 2007, 13:45:26)  [GCC
                        4.1.2 20070925 (Red Hat 4.1.2-33)]
              platform: linux2

REQUIRED DEPENDENCIES
                 numpy: 1.1.0
             freetype2: 9.16.3

OPTIONAL BACKEND DEPENDENCIES
                libpng: 1.2.29
               Tkinter: no
                        * Using default library and include directories for
                        * Tcl and Tk because a Tk window failed to open.
                        * You may need to define DISPLAY for Tk to work so
                        * that setup can determine where your libraries are
                        * located. Tkinter present, but header files are not
                        * found. You may need to install development
                        * packages.
              wxPython: no
                        * wxPython not found
                  Gtk+: gtk+: 2.12.5, glib: 2.14.6, pygtk: 2.12.0,
                        pygobject: 2.14.0
                        * Could not find Gtk+ headers in any of
                        * '/usr/local/include', '/usr/include', '.'
                    Qt: no
                   Qt4: no
                 Cairo: 1.4.12

OPTIONAL DATE/TIMEZONE DEPENDENCIES
              datetime: present, version unknown
              dateutil: matplotlib will provide
                  pytz: matplotlib will provide

OPTIONAL USETEX DEPENDENCIES
                dvipng: 1.5
           ghostscript: 8.61
                 latex: 3.141592

EXPERIMENTAL CONFIG PACKAGE DEPENDENCIES
             configobj: matplotlib will provide
      enthought.traits: matplotlib will provide

[Edit setup.cfg to suppress the above messages]
============================================================================
running build
running build_py
copying lib/matplotlib/mpl-data/matplotlibrc -> build/lib.linux-x86_64-2.5/matplotlib/mpl-data
copying lib/matplotlib/mpl-data/matplotlib.conf -> build/lib.linux-x86_64-2.5/matplotlib/mpl-data
running build_ext
building 'matplotlib.backends._backend_gdk' extension
creating build/temp.linux-x86_64-2.5
creating build/temp.linux-x86_64-2.5/src
gcc -pthread -fno-strict-aliasing -DNDEBUG -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -D_GNU_SOURCE -fPIC -fPIC -I/usr/lib64/python2.5/site-packages/numpy/core/include -I/usr/local/include -I/usr/include -I. -I/usr/local/include -I/usr/include -I. -I/usr/include/python2.5 -c src/backend_gdk.c -o build/temp.linux-x86_64-2.5/src/backend_gdk.o
src/backend_gdk.c:9:25: error: pygtk/pygtk.h: No such file or directory
src/backend_gdk.c: In function ‘pixbuf_get_pixels_array’:
src/backend_gdk.c:28: error: ‘PyGObject’ undeclared (first use in this function)
src/backend_gdk.c:28: error: (Each undeclared identifier is reported only once
src/backend_gdk.c:28: error: for each function it appears in.)
src/backend_gdk.c:28: error: ‘py_pixbuf’ undeclared (first use in this function)
src/backend_gdk.c:29: error: ‘GdkPixbuf’ undeclared (first use in this function)
src/backend_gdk.c:29: error: ‘gdk_pixbuf’ undeclared (first use in this function)
src/backend_gdk.c:37: warning: implicit declaration of function ‘GDK_PIXBUF’
src/backend_gdk.c:43: warning: implicit declaration of function ‘gdk_pixbuf_get_height’
src/backend_gdk.c:44: warning: implicit declaration of function ‘gdk_pixbuf_get_width’
src/backend_gdk.c:45: warning: implicit declaration of function ‘gdk_pixbuf_get_has_alpha’
src/backend_gdk.c:48: warning: implicit declaration of function ‘gdk_pixbuf_get_pixels’
src/backend_gdk.c:48: warning: cast to pointer from integer of different size
src/backend_gdk.c:53: warning: implicit declaration of function ‘gdk_pixbuf_get_rowstride’
src/backend_gdk.c: In function ‘init_backend_gdk’:
src/backend_gdk.c:72: warning: implicit declaration of function ‘init_pygtk’
error: command 'gcc' failed with exit status 1


-- 
Your own civil rights and the quality of your life heavily depend on how
software is used *around* you:            http://digifreedom.net/node/84


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]