[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora 9 & runlevel 3



Tom Horsley wrote:
On Sun, 15 Jun 2008 19:25:05 -0400
Bob Barrett <bobbrrtt earthlink net> wrote:

I have never before had this kind of problem. The kind where
the developers go off on some experimentation tangent, but
supply so little information for the users. I'm disappointed in
Fedora 9.

That's hard to believe: It has been my experience that describes
the primary development model for all open source software :-).

/etc/inittab leads off with "inittab is only used by upstart for the default
runlevel." Therefore, it appears that it is used to set the default runlevel.

However, according to this forum exchange, it's ignored by upstart.

If you look at /etc/event.d/rcS you'll see the code that looks at
/etc/inittab to pick up the runlevel.

You'll also see that it fails to ignore lines starting with '#' :-).

I got all my virtual machines at work to start in runlevel 3 perfectly
fine, but I merely changed the 5 to a 3, I didn't comment out the one
line and add a new one like you show in your example.

You are probably under the mistaken impression that open source projects
are intended to be tools people use to get work done - that's not it at all.
It is really a large interactive adventure/puzzle game where the only
inflexible rule is that if anyone ever figures out how to get useful
work done, they have to change it completely right away :-).

Thanks to all those who replied.

Tom,

My apologies to the developers.

I really do enjoy the adventure/puzzle game, but I also need the other and
I will not use MS Windows on my own time.

I'm not a programmer, but I'm trying to rectify that. I'm O.K. with basic
BASH scripts, and I'm slowly teaching myself C. Slowly, because of
distractions, procrastination, and it's not easy to cram more new
information into an old brain that's full of other stuff,

I realize /etc/event.d/rcS and /etc/inittab are not bash scripts, and
bash rules would not apply, but I was under the impression that "#"
signified a comment in most system scripts, beyond the "magic cookie"
or sha! at the beginning of the file. /etc/inittab, particularly, seems
to be setup that way.

What kind of scripts are they, anyway? Kernel language, maybe?

I like to tag my changes and preserve the default as a comment in
configuration files. A habit developed early, and still with me.
Probably came from feeling insecure about my changes, and a desire to
be able to easily return to what worked. I have always in the past done
that with inittab, and it has always in the past worked. Now I know.

I probably looked at /etc/event.d/rcS so many times that I saw less each
time. What is missing?

Now, to pick up new tracks with KDE.

About the changes in Fedora 9; a couple of thoughts:

Change is exciting and fun; except when it comes without choice.

Evolution and revolution are both natural occurrences; evolution is
more gracefully accepted.

Again, thanks for your help.

Bob


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]