[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Sound doesn't work after suspend/hibernate Fedora 9



On Thu, Jun 19, 2008 at 6:26 AM, Patrick <fedora-list puzzled xs4all nl> wrote:
On Wed, 2008-06-18 at 19:13 -0700, Endy wrote:
> Matt Morgan wrote:
> > When I boot my computer all the way up, sound works fine.
> >
> > When I return from suspend or hibernate, sound is gone. I don't get
> > any obvious error messages, I just don't hear anything.
> >
> > It's Fedora 9, i386, on an intel board with integrated Intel sound.
> > Any ideas/suggestions?
> >
> > Thanks,
> > Matt
> I had a similar problem with my dell...but that was on f8.  I haven't
> had any issues in f9.  It's a pain in the ass, but dropping into
> runlevel 3, rmmod-ing the sound module (probably snd-hda-intel) and then
> loading it again and going back to init 5 solved the problem when I was
> experiencing it.

You can configure it so it gets done automagically. Quoting from
http://people.freedesktop.org/~hughsient/quirk/quirk-suspend-advanced.html

To do this, create a file in /etc/pm/config.d/unload_modules and add the
following line:

SUSPEND_MODULES="b44"

You'll also need to make this script executable, which you can do using:
chmod +x /etc/pm/config.d/unload_modules

Replace b44 with the name of your kernel sound module(s) and give it a try.

Regards,
Patrick

Thanks to you both. I think I may have bigger problems.

I tried the automagic way ... it didn't work. Maybe snd-hda-intel isn't right? How do I know? When I try 'modprobe -l snd*' I get 122 results.

I tried the manual way ... turns out that sound isn't all that I lose after suspend/hibernate. I can't get to the console on ctrl-alt-f1. No video is sent. It works after a complete reboot.

What's going on here?

Thanks a lot,
Matt

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]