[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Wireless problems.



Matthew Saltzman wrote:
On Mon, 2008-06-23 at 13:56 -0400, Mark Haney wrote:
Matthew Saltzman wrote:
On Mon, 2008-06-23 at 11:53 -0400, Mark Haney wrote:
Timothy Murphy wrote:
Mark Haney wrote:

I will mention that when I reboot, and I look in 'Network' in GNOME,
that I see 2 wireless cards listed.  Originally, it showed 'wlan0' and
'wlan0.bak', along with 'eth0' and 'eth0.bak'.  I don't know how that
happened, but I'm wondering if kudzu doing something.  Even when I
deleted the wlan0.bak option and rebooted, same thing.
I think this is part of the completely crazy pre-NM WiFi setup.

NM is crazy too, but in a different way.

Did you try, incidentally, "iwconfig wlan0 essid <whatever>"?
Do you have the ESSID set in /etc/sysconfig/network-scripts/ifcfg-wlan0 ?

Also maybe worth trying "iwconfig wlan0 MODE Managed" or "MODE AdHoc".

Ps I'm not a WiFi guru, just a sufferer from it.



See, on my other wireless system (laptop running Gentoo), I always fire up my wireless this way with no trouble, no matter where I am. (Uh, the manual CLI way) The script I use has never failed me to launch iwconfig and then bring up the interface.

In Fedora, even from the CLI I cannot get the interface to connect. It's UP, from the standpoint that I have an entry in ifconfig that tells me it's up. The modules are loaded (and I've tried load/unload). I've tried the other AP modes and still nothing. I just don't understand what changed in a week. This is the one system I haven't wired because of it's location and so far I've not had trouble with it.

At this point, I'm tempted to try Gentoo on it and see if that makes a difference, just to make sure it's not some weirdness with Linux in general with that card.
You might try the following:

      * Open system-config-network.
      * Delete all wireless interfaces and devices.
      * Reboot, and let the hardware detector re-detect them.
      * Try connecting again.


Yep.  Tried that too.  No go.  It's the craziest thing.

Did it get rid of the multiple copies?  Did it correctly detect the
cards?

It did.  Until a second reboot. Then they came back.

Do you have Windows on the machine, and does it work there?  Does the
Ubuntu or Knoppix live CD work?  I came late to the thread, so did it
work with older kernels?  Does it work connecting with
system-config-network, or ifup, or wpa-supplicant?

Yes I have XP on that box and the card works perfectly (gasp!) there. I've never tried wpa-supplicant. This connection is totally open, unencrypted since I live so far away from any of my neighbors. Unless, of course the squirrels or deer in my woods has connectivity. :)



A that point, I'd consider filing a bug.  John Linville handles the
wireless stuff, and he's usually been pretty responsive.

The problem is, I don't know what the problem is, so don't know what to file.


Wireless is a seriously tricky business.  From what I've read here and
on the fedora-devel, fedora-testing, and NetworkManager mailing lists,
I'm not surprised that it's still kind of flaky on Linux.  It's gotten
dramatically better over the last couple of Fedoras, though.


--
Libenter homines id quod volunt credunt -- Caius Julius Caesar


Mark Haney
Sr. Systems Administrator
ERC Broadband
(828) 350-2415

Call (866) ERC-7110 for after hours support


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]