[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Problem with NIS in Fedora 9



Greetings.  We've installed Fedora 9 on a Pentium 4 system (i386).  This
system is part of a group of 20 or so systems that get NIS service from
one of our servers.  Most of the other systems in this group are running
Fedora 8.  The system in question is the only one running Fedora 9.

On all the Fedora 8 systems the NIS service works just fine.  On the
Fedora 9 system the ypbind service seems to start but never really makes
it all the way:

    [root f9sys ~]# ypwhich
    ypwhich: Can't communicate with ypbind

    [root f9sys ~]# service ypbind restart
    Shutting down NIS service:                                 [  OK  ]
    Starting NIS service:                                      [  OK  ]
    Binding NIS service: ...............                       [  OK  ]

    [root f9sys ~]# ypwhich
    ypwhich: Can't communicate with ypbind

When this happens we get a message in /var/log/messages:

    Jun 24 21:08:50 f9sys
    ypbind: NIS domain: f9sysdom, NIS server:

I.e., we have the correct domain name, but no server is ever listed.

But on this system, as on all other systems in the group, we have in
/etc/yp.conf:

    domain f9sysdom server our.nis.server

We have checked that the problem does not seem to be related to
iptables, TCP wrappers, or selinux.

We also have "our.nis.server" listed in /etc/hosts, and

    hosts:      files dns nis

in /etc/nsswitch.conf, so it would seem not to be a DNS problem.

If you have any thoughts about this, please send 'em my way.

Thanks.

-- Mike


      


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]