[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

different mounts leads to different permissions/acl?



Hoi every

we use a cvs environment, where the repository is mounted from the main cvs-server into each participants work-space.

before fedora 9, we used cifs mounts exclusively.
with fedora 9, we started using sshfs.

this afternoon, i had the repository mounted using sshfs.

i had a failure when  committing a cvs module.
cvs said:

...
Checking in module/779930879.htm;
/home/cvs/r/repository/module/779930879.htm,v  <--  779930879.htm
new revision: 1.2; previous revision: 1.1
cvs [commit aborted]: cannot rename file /home/cvs/r/repository/module/,779930879.htm, to /home/cvs/r/repository/module/779930879.htm,v: Operation not permitted
[cvs myws ~/work]$


i unmounted the repository and remounted it using cifs, whereupon the commit worked fine.

i then wanted to see, what the difference is in file permissions between the two mount versions, and to my surprise, found none: user:group were the same with both mounts, also the file permissions were the same.

then i tried to do manually the move cvs had complained about and got the following:

repository cifs mounted:
[cvs myws ~/work]$ mv /home/cvs/r/repository/module/,779930879.htm /home/cvs/r/repository/module/779930879.htm,v mv: try to overwrite `/home/cvs/r/repository/module/779930879.htm,v', overriding mode 0544 (r-xr--r--)? y
[cvs myws ~/work]$


repository sshfs mounted:
[cvs myws ~]$ mv /home/cvs/r/repository/module/,779930879.htm /home/cvs/r/repository/module/779930879.htm,v mv: cannot move `/home/cvs/r/repository/module/,779930879.htm' to `/home/cvs/r/repository/module/779930879.htm,v': Operation not permitted
[cvs myws ~]$

i made sure, that the file i wanted to move had exactly the same permissions as when the repository was cifs mounted: it had the same permissions (r-xr--r--).

for the cifs mount we use the standard fedora 9 samba installation for [home] shares:

[homes]
        comment = Home Directories
        browseable = no
        writable = yes
;       valid users = %S
;       valid users = MYDOMAIN\%S


as far as i can see, the difference is minimal, but it makes cvs commit fail, when the repository is sshfs mounted.

can somebody explain, what the difference is, and how i could correct/work-around it?

thanks in advance.

suomi



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]