[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

nvidiafb problems



I have been having this problem for a while.  I was told on the fedora IRC channel that "this has nothing to do with fedora" and to stop my blathering, but I think that it is something that perhaps the community should at least be aware of and perhaps even hopefully can help me to solve.

I am having an odd problem with nvidiafb.  I have written a program to do a mandelbrot set over framebuffer, just to learn how to make mandelbrot sets and how to use the framebuffer.  The program worked fine on some old hardware I had - an older nvidia AGP card.  But after I upgraded to a 6200, along with a Dual-core X2-based motherboard, suddenly it stops working.  More accurately, the framebuffer works fine at 1280x1024 until I start the program, at which time the image moves rapidly across the screen, reminiscent of an old TV that has lost its horizontal sync.  This does not happen at 640x480, and going up in resolution the side-to-side motion gets progressively faster.

Obviously, this is useless for my purposes.

I worked with the directfb people to try to rule out directfb being the culprit.  After I managed to get this working under VESA (with no acceleration, obviously, so it's almost useless), that pretty much ruled out directfb being the problem.  So I'm having to think that for some reason the nvidiafb driver is just not playing nice with my card.

I should also note that it seems to detect an "NV22" card, with 64M of memory.  I have an NV44 card with 256M of memory.  Oddly enough, it seems to get that number from the PCI device ID, and really doesn't seem to care what it actually *is*.

I'll paste some lspci output, etc., in hopes that it is useful.

lspci for this card:
03:00.0 VGA compatible controller: nVidia Corporation NV44A [GeForce 6200] (rev a1)

dmesg output on module being loaded:
nvidiafb: Device ID: 10de0221
nvidiafb: CRTC0 analog not found
nvidiafb: CRTC1 analog found
nvidiafb: EDID found from BUS1
i2c-adapter i2c-2: unable to read EDID block.
i2c-adapter i2c-2: unable to read EDID block.
i2c-adapter i2c-2: unable to read EDID block.
nvidiafb: CRTC 0appears to have a CRT attached
nvidiafb: Using CRT on CRTC 0
nvidiafb: MTRR set to ON
Console: switching to colour frame buffer device 160x64
nvidiafb: PCI nVidia NV22 framebuffer (64MB @ 0xC0000000)

I should also note that a program that worked JUST FINE on the old hardware using the directfb libraries now randomly segfaults.

--Russell

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]