[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Hardware browser??



On Mon, 30 Jun 2008 19:33:01 +0100, Frank Murphy wrote:

> On Mon, 2008-06-30 at 18:27 +0000, Beartooth wrote:
	[...] 
>> 	So will either an upgrade with my original F9 DVD, or "yum
>> upgrade" handle that? Or will I have to re-install the rpmfind
>> download?
 
>> 	And how do I use it? Just log out and in? Run the livna
>> configurator again? Some other configurator?
 
 
> 
>       * Fedora :
>       * Fedora Core 2 up to Fedora Core 6 :
>         http://washington.kelkoo.net/epia
>       * Fedora 7 and newer : just run 'yum install
>         xorg-x11-drv-openchrome'.
>       * Fedora 9 and newer : openchrome is the default driver for VIA
>         IGPs.

	Well, I started with a small goof, misremembering for a moment 
which OS is on which machine. I don't *think* that made trouble -- I 
installed from rpmfind, and yum install just says xorg-x11-drv-openchrome 
is already there.

	Anyway on PC #1 (F8) I ran the Display applet; it let me change 
the hardware seting (to generic LCD 1680x1050; my HP w2207h is not listed 
under HP yet), but not the display setting. 

	I logged out and back in. The display is distinctly better -- but 
clicking the applet launcher does nothing. Large UH-OH.

	So I tried the CLI, and got this (with no display) : 

	=====		=====		=====
[root localhost ~]# system-config-display &
[1] 28747
[root localhost ~]# Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 381, in <module>
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig, 
rhpxl.videocard.VideoCardInfo())
  File "/usr/share/system-config-display/xConfigDialog.py", line 533, in 
__init__
    self.state.recalc_mode()
  File "/usr/lib/python2.5/site-packages/rhpxl/xhwstate.py", line 387, in 
recalc_mode
    self.colordepth = availableDepth[-1]
IndexError: list index out of range

[1]+  Done                    system-config-display
	=====		=====		=====

	That "out of range" warning is deadly.

	I tried another twist :

	=====		=====		=====
[btth localhost ~]$ cat /etc/X11/xorg.conf
# Xorg configuration created by system-config-display
	[....]
Section "Monitor"
        Identifier   "Monitor0"
        ModelName    "LCD Panel 1280x1024"
        HorizSync    31.5 - 64.0
        VertRefresh  56.0 - 65.0
        Option      "dpms"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "vesa"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

[btth localhost ~]$
	=====		=====		=====

	I'd be pretty sure rebooting, or even logging out and in, would 
render the machine useless -- but how can xorg.conf be still set to 
1280x1024??

	And how can I rescue this install??

	Here I thought I was cruisin' to a smooth upgrade ....
-- 
Beartooth Staffwright, PhD, Neo-Redneck Linux Convert
Fedora 8 & 9; Alpine 1.10, Pan 0.132; Privoxy 3.0.6;
nine (count 'em -- nine) different browsers
Remember I know precious little of what I am talking about.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]