[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

another EDID question, if i might



  i finally have a decent handle on interpreting and
manipulating EDID information based on a couple threads
here not that long ago, but i just ran into another
curious problem.  someone handed me a piece of video
processing equipment that (allegedly) had decent EDID
programmed into it, i hooked up my WUXGA laptop, started
the X server, and what i got in the X server log was:

...
(II) RADEON(0): I2C device "DVI-0:ddc2" registered at address 0xA0.
(II) RADEON(0): EDID vendor "XXX", prod id 26
(II) RADEON(0): Using EDID range info for horizontal sync
(II) RADEON(0): Using EDID range info for vertical refresh
(II) RADEON(0): Printing DDC gathered Modelines:
(II) RADEON(0): Modeline "1920x1200"x0.0 156.87 1920 1978 2010 2100 1200 1206 1212 1236 +hsync +vsync (74.7 kHz)
(II) RADEON(0): Output: DVI-0, Detected Monitor Type: 3
(II) RADEON(0): EDID data from the display on output: DVI-0 ----------------------
(II) RADEON(0): Manufacturer: XXX  Model: 1a  Serial#: 0
(II) RADEON(0): Year: 2006  Week: 1
(II) RADEON(0): EDID Version: 1.3
(II) RADEON(0): Digital Display Input
(II) RADEON(0): DFP 1.x compatible TMDS
(II) RADEON(0): Indeterminate output size
(II) RADEON(0): Gamma: 2.20
(II) RADEON(0): No DPMS capabilities specified(II) RADEON(0):
Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
(II) RADEON(0): First detailed timing is preferred mode
(II) RADEON(0): GTF timings supported
(II) RADEON(0): redX: 0.625 redY: 0.345   greenX: 0.350 greenY: 0.580
(II) RADEON(0): blueX: 0.140 blueY: 0.095   whiteX: 0.320 whiteY: 0.355
(II) RADEON(0): Manufacturer's mask: 0
(II) RADEON(0): Supported additional Video Mode:
(II) RADEON(0): clock: 156.9 MHz   Image Size:  0 x 0 mm
(II) RADEON(0): h_active: 1920 h_sync: 1978 h_sync_end 2010 h_blank_end 2100 h_border: 0 (II) RADEON(0): v_active: 1200 v_sync: 1206 v_sync_end 1212 v_blanking: 1236 v_border: 0
...

  huh?  the above looks a bit strange here:

(II) RADEON(0): Modeline "1920x1200"x0.0 156.87 1920 1978 2010 2100 1200 1206 1212 1236 +hsync +vsync (74.7 kHz)

  "0.0"??  shouldn't that represent the refresh rate?
is that a valid value?  apparently, my laptop is refusing
to generate a video signal on the DVI output because,
perhaps, it doesn't like that value.

  and then there's this:

(II) RADEON(0): clock: 156.9 MHz   Image Size:  0 x 0 mm

"0 x 0 mm"?? i'm not sure what to make of that either, but
i'm going to be handing this back to the person who programmed
that piece of equipment and ask whether that information is
supposed to be correct.

  thoughts?

rday



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]