[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora / RedHat - The problem



On Sun, 2008-11-02 at 23:51 -0500, Brian C. Huffman wrote:
> Alright  I hate Microsoft.  I really do.  But here I am at 11:45pm on 
> a Sunday night and my wife needs to print a paper for tomorrow.
> 
> My Fedora cups  / samba server worked before and now it doesnt.  Was 
> it an update that broke?  I dunno.  But this is why RedHat / Fedora is 
> never going to take the upper hand.   Reboots on both platforms, a bunch 
> of tcpdumps and still no idea.  No real user should have to go through 
> this.  Sure  Ill figure it out.  But is that what someone wants when 
> theyve got a paper to print thats due tomorrow?

A few months ago I installed a new HP C5180 multifunction printer on my
home network. I have 3 machines at home. Here's what happened when
configuring the printer in each one:

1) My wife's iMac: "Do you want to use this Printer?". "Yes". Total
time, 5 seconds.

2) My Fedora desktop: "yum install hplip". Run hp-setup and answer some
questions. Total time, say 15 minutes including download time.

3) My daughter's Toshiba laptop with Windows Vista: insert the install
CD *which came with the printer*. Chug chug chug. Printer not working,
in fact not even visible to Vista. Download a later install CD from
hp.com. Still not working. Contact HP Support by email ... dolly back,
fade to black ... Three days later, after half a dozen emails back and
forth, get a newer version of driver CD, which can't be installed
directly but has to be physically burned to a CD. Finally get the thing
sort of working, when it's the right phase of the moon (I'm skipping the
dozen or so system reboots of course).

So, whose fault is all this? The driver belongs to HP, the system
belongs to MS. My answer: the fault is the whole blasted Windows
ecosystem.

poc



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]