[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: mplayer dependencies on RPM Fusion

On Tue, 4 Nov 2008 00:08:06 +0100, Andras Simon wrote:

> On 11/3/08, Michael Schwendt <mschwendt gmail com> wrote:
> > On Mon, 3 Nov 2008 23:03:45 +0100, Andras Simon wrote:
> >
> >> It seems that mplayer's dependencies on RPM Fusion include (perhaps
> >> indirectly) mencoder, samba-common and samba-winbind. Are these really
> >> necessary? This does matter on a netbook with 4G SSD.
> >
> > It "seems"? No, it's a fact. You can demonstrate it easily.
> >
> >   $ rpm -qpR mplayer-1.0-0.97.20080903svn.fc9.1.i386.rpm|grep smb
> >   libsmbclient.so.0
> You can, if you've updated mplayer already. I haven't, because I
> thought I'd ask first.


$ rpm -q mplayer
package mplayer is not installed

You, too, can download the package with your favourite browser or
yumdownloader to examine it. No updating of installed packages is
> > And with an extracted /usr/bin/mplayer:
> >
> >   $ ldd mplayer|grep smb
> >   libsmbclient.so.0 => /usr/lib/libsmbclient.so.0 (0x065a3000)
> Ditto.

Same here. You can extract files from an uninstalled RPM package.
> > Now, to answer your question, complete the rest of the exercise yourself
> > and find out where/how exactly the smbclient lib is used inside mplayer.
> It's not exactly what I'd call an answer, but thanks anyway.

Why not? The main mplayer currently is linked with the Samba Client
library. Either that's needed for a some feature, or it's a bug.
Find out what's the case.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]