[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Java plugin stopped working.



Hi,

Steve wrote:
---- Deepak Bhole <dbhole redhat com> wrote:
* Steve <zephod cfl rr com> [2008-11-05 13:30]:
---- Deepak Bhole <dbhole redhat com> wrote:
* Steve <zephod cfl rr com> [2008-11-04 10:42]:
I'm using 2.22.2 of ephipany and my java plugin seems to have stopped working presumably as a result of a recent update (nspluginwrapper-1.1.2.2.fc9.x86_64?).

...

Hi Steve,

If you type in about:plugins in the address bar and hit enter, do you
see Java in the list that shows up?
No,  there is no java in the list.

If it does not, can you paste the output of:
ls -l /etc/alternatives/*javaplugin*
$ ls -l /etc/alternatives/*javaplugin*
lrwxrwxrwx 1 root root 63 2008-11-03 14:55 /etc/alternatives/libjavaplugin.so.x86_64 -> /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/gcjwebplugin.so

Thanks for taking the time to help.

Alright, so that link looks good. We need to figure out now if that plugin exists, and if mozilla is expected to be seeing it. So, can you post the output of:

ls -l /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/gcjwebplugin.so

and:

ls -l /usr/lib64/mozilla/plugins/*java*

Deepak

[sblackwell asa-ws-053 ~]$ ls -l /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/gcjwebplugin.so
ls: cannot access /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/gcjwebplugin.so: No such file or directory

So that looks like a problem:

[sblackwell asa-ws-053 ~]$ locate gcjwebplugin.so
/usr/lib/gcj-4.3.0/libgcjwebplugin.so
/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/gcjwebplugin.so
/usr/lib64/gcj-4.3.0/libgcjwebplugin.so
/usr/share/doc/libgcj-4.3.0/README.libgcjwebplugin.so

This is odd, to have the JDK (/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/), you must have installed java-1.6.0-openjdk-devel. Therefore, you must have installed java-1.6.0-openjdk, which in turn provides the /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/ directory (java-1.6.0-openjdk-plugin provides /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/gcjwebplugin.so). Seems like your links got nuked or you lost some files somewhere.

The only thing I can suggest is removing all your java-1.6.0-openjdk packages, and reinstall them all. Be sure you at least have java-1.6.0-openjdk, and java-1.6.0-openjdk-plugin.


Let me know if that works,
Lillian


Seems there is an extra jre in the path.

[sblackwell asa-ws-053 ~]$ ls -l /usr/lib64/mozilla/plugins/*java*
lrwxrwxrwx 1 root root 41 2008-11-03 14:55 /usr/lib64/mozilla/plugins/libjavaplugin.so -> /etc/alternatives/libjavaplugin.so.x86_64

Steve



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]