[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: libssl.so.6 required by git



Sashan Govender wrote:
Why are my dependecies broken?

I upgraded Fed 8 to Fed 9 yesterday and have noticed this:

git: error while loading shared libraries: libssl.so.6: cannot open
shared object file: No such file or directory

Where did the git package come from? Can you post the output of "rpm -qi git"?

The git I have installed (f9, clean install, 64-bit) is:

git-1.5.6.5-1.fc9.x86_64

It depends on libssl.so.7 and libssl3.so:

$ ldd `which git` | grep ssl
        libssl3.so => /lib64/libssl3.so (0x00000033eb600000)
        libssl.so.7 => /lib64/libssl.so.7 (0x00000033e4e00000)

These are provided by openssl-0.9.8g-9.fc9.

Regards,
Bryn.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]