[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Document Scanners that work with F9



Todd Denniston writes:

Sam Varshavchik wrote, On 11/05/2008 06:35 PM:
I, personally, use the Cannon MF-4270. I had to hack some bugs out of sane's pixma driver, but once I did that, it worked fine. The fixes went upstream, they should be in the next version of sane, so until then you'll have to pull them out of CVS and temporarily build your own driver.

The MF-4270 is really a multifunction scanner/copier/printer/fax machine. AFAIK, there is no support for the printer part of it, in CUPS, but I don't need the printer+fax functionality. It works fine for me as a scanner+copier. Supports both the flatbed and the document feeder, for scanning.


The actual printer _device_ driver for CUPS is often gutenprint[1].

I already have gutenprint installed. I'm not sure how gutenprint is supposed to interface with CUPS, but when I try to select the printer, this Canon model is not listed.

I have seen a far amount of traffic on the gutenprint list[2] where some folks are trying to support some of the cannon equipment. And as you don't seem to be adverse to working out of a dev repository, perhaps you might want to take a look and see if your multifunction device is already supported or if you could give them the few needed pointers to get it supported.

Well, I still don't see this Canon model listed as supported in the documentation in the latest, a fairly recent, release.

The only reason I could hack sane is because its supported for the scanner was already there, it just had some bugs. A complete absence of support for the entire printer is quite a different beast.


Attachment: pgprGfNxMMaGQ.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]