[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: dependency champion?



On Thu, 6 Nov 2008 22:13:55 +0000 (UTC), Beartooth wrote:

> 	Pango should never have required libthai in the first place -- 
> not in a release -- not if libthai is anything remotely like what its 
> name suggests.

You could have replaced your overly long mail with the result of taking a
look at what exactly in Pango requires LibThai. Here, look!

$ rpm -ql pango|grep thai
/usr/lib/pango/1.6.0/modules/pango-thai-fc.so
/usr/lib/pango/1.6.0/modules/pango-thai-lang.so

$ ldd /usr/lib/pango/1.6.0/modules/*.so|grep thai
/usr/lib/pango/1.6.0/modules/pango-thai-fc.so:
/usr/lib/pango/1.6.0/modules/pango-thai-lang.so:
        libthai.so.0 => /usr/lib/libthai.so.0 (0x00281000)

$ ldd /usr/lib/libpango*|grep thai
$

Files that likely could go into an optional sub-package. Though,
there's an additional explicit "Requires: libthai ..." in the spec,
too:

$ grep -i thai pango.spec 
%define libthai_version 0.1.9
Requires: libthai >= %{libthai_version}
BuildRequires: libthai-devel >= %{libthai_version}
- Bump libthai requirement.
- [Build]Require libthai[-devel]
- Fix problem with corrupt Thai shaper


> But do you really want to defend the fact that that requirement 
> was not found, or else found and not remedied, by any other Fedora 
> developers? 

Did I defend it? No. I only pointed out that currently, Pango requires
this library, and hence you cannot "yum remove" the lib without removing
Pango and hundreds of deps that require Pango.

What exactly is the problem? It's just a tiny system library isn't it?
Increased core functionality.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]