[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Kismet and SELinux



I am running an F9 system with SELinux enabled on a laptop.
I recently installed kismet (yum install kismet) to check local wireless
channels so I can ensure my AP does not conflict with other boxes nearby.

I made the usual mods to the config files to set up sources etc and change
the suiduser but when I try to run kismet as root (in exactly the same way
as previously on boxes with SElinux disabled), I get an avc denial and on
the terminal I get:
FATAL: Could not open SSID track file '/home/mike/ssid_map': permision
denied.

The SELinux denial contains a Summary:
SELinux is preventing the kismet_server from using potentially mislabeled
files (./ssid_map).

It suggested using restorecon but this makes no difference. The context
remains as previously:
system_u:object_r:user_home_t:s0
I removed the file and tried again but kismet won't start if the file is
absent. 

I also tried to use chcon to set the context for this file - and this also
makes no difference - at least with the contexts I tried for kismet_log_t
and kismet_t is not permitted.

Can anyone suggest how I might work around this?
-- 
View this message in context: http://www.nabble.com/Kismet-and-SELinux-tp20457544p20457544.html
Sent from the Fedora List mailing list archive at Nabble.com.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]