[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: How to get sound working in F9



Mikkel L. Ellertson wrote:
GN wrote:
Hi Waleed,

Sound card is Intel Corp 82801H (ICH Family) HD Audio Controller (Rev 03)

/usr/bin/alsamixer gives 'No mixer elems found'.

Also, clicking on the volume contrtol gives the following:

The volume control did not find any elements and/or devices to control.
This means either that you don't have the right GStreamer plugins
installed, or that you don't have a sound card configured.

You can remove the volume control from the panel by right-clicking the
speaker icon on the panel and selecting "Remove From Panel" from the menu.

I am not sure about the 82801H, but the 82801G can have problems if
yours is not one of the ones that ALSA know the configuration of.
You then need to specify a model in modprobe.conf to let the driver
know what configuration to use. (The chip can be configured in many
different ways, depending on how the manufacturer wants to use it.)

To make things more interesting, the model that mostly works in one
version of ALSA may not work in the next one. For example, this one
used to work on my Toshibs A105-S4004:

options snd-hda-intel index=0 single_cmd=1 model=ref

In a later version, I had to use:

options snd-hda-intel index=0 model=auto

I still have to find the correct line for the current version when I
have the spare time to do it.

Mikkel

Thanks Mikkel, you have pointed me in the right direction. The sound controller is found. The following line is from /sbin/lspci

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

The output of /sbin/lsmod | grep snd shows that sound modules are loaded. Does the following make any sense to you?

snd_hda_intel         336928  0
snd_seq_dummy           6660  0
snd_seq_oss            30364  0
snd_seq_midi_event      9600  1 snd_seq_oss
snd_seq                48448  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         10124  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            42496  0
snd_mixer_oss          16768  1 snd_pcm_oss
snd_pcm                67076  2 snd_hda_intel,snd_pcm_oss
snd_timer              21640  2 snd_seq,snd_pcm
snd_page_alloc         11400  2 snd_hda_intel,snd_pcm
snd_hwdep              10500  1 snd_hda_intel
snd 48312 10 snd_hda_intel,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
soundcore               9288  1 snd

Do I have to start the sound server somehow or just put in the options as you suggest?

Ta,

GN


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]