[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

preupgrade f8 to f9 -- two issues



I just updated one of my computers from f8 to f9 using preupgrade and have two
minor issues.

First issue:

After running preupgrade and going through all of the steps to get a working
updated system, everything booted back up and appears to be ok.  I then ran
"yum update" to update everything to the latest f9 version and then, when I
rebooted that time all I got was a black screen with "GRUB".

I burned boot.iso from the F9 install dvd image onto a cd and booted with that
and ran linux rescue.  After getting to a prompt I ran "chroot /mnt/sysimage"
and then "grub-install /dev/sda".  Exited the shell and rebooted and everything
now works fine.  But I have a strange-looking grub.conf file:

QUOTE:
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
#          initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.26.6-79.fc9.x86_64)
	root (hd0,0)
	kernel /vmlinuz-2.6.26.6-79.fc9.x86_64 ro
root=UUID=6264a92e-b26c-4a76-9281-f4274045e207 rhgb quiet
initrd /initrd-2.6.26.6-79.fc9.x86_64.img title Fedora (2.6.26.6-49.fc8)
	root (hd0,0)
	kernel /vmlinuz-2.6.26.6-49.fc8 ro root=/dev/VolGroup00/LogVol00 rhgb
quiet initrd /initrd-2.6.26.6-49.fc8.img
END OF QUOTE

Note the  "root=UUID=6264a92e-b26c-4a76-9281-f4274045e207".  instead of the
usual  "root=/dev/VolGroup00/LogVol00".

What's going on there?

Second issue:

When I run firefox by typing firefox at a gnome terminal prompt I get this
message in the terminal window:

QUOTE:
which: no soundwrapper in
(/usr/lib64/qt-3.3/bin:/usr/kerberos/bin:/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/home/frank/bin)
which: no soundwrapper in
(/usr/lib64/qt-3.3/bin:/usr/kerberos/bin:/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/home/frank/bin)
END OF QUOTE

When I run firefox the same way on this computer (which I updated from f8 to f9
a few days ago "the hard way" by using the "yum upgrade" method instead of
preupgrade, I don't get that error message.

It looks like something is missing on that computer that's present on this
computer, but what is it?  I went to youtube with firefox on that computer and
watched a video there and I had sound.



-- 
MELVILLE THEATRE ~ Melville Sask ~ http://www.melvilletheatre.com
DRY CLEANER BUSINESS FOR SALE ~ http://www.canadadrycleanerforsale.com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]