[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Domain of sender address ... does not resolve



Patrick O'Callaghan wrote:
On Fri, 2008-11-14 at 15:07 -0500, Bill Davidsen wrote:
g wrote:
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Bill Davidsen wrote:

The nameservers in /etc/resolv.conf are the authoritative DNS for the domain, both are up, etc.
mind posting your /etc/resolv.conf
==========

# generated by NetworkManager, do not edit!

domain tmr.com

search tmr.com

nameserver 192.168.12.100
nameserver 192.168.12.101

This is actually pretty useless without seeing the named config file on
192.168.12.100 (and 101 I guess). As someone else already said, it's
likely to be a reverse lookup failure.

Actually a "I've been down with pneumonia for almost three weeks and tried to configure three servers in a day" error. No lookup issues, these are the IPs of my internal DNS for this (tmr.com) domain. And it works for ~12 other systems just fine.

What happened was that when I configured the system to accept mail on any IP, I whizzed thru sendmail.mc, changed a number of things, including LOCAL_DOMAIN, changing localhost.localdomain to tmr.com. After I noted with wireshark that it not only wasn't failing, but not even asking, the penny dropped. Stuck "dnl" at the start of the line, ran make, restarted sendmail, all works.

That's what comes from trying to do "something easy" when you are recovering from being sick, pure operator error. I only admit it in case someone else shoots themselves in the same foot.

Thanks for all of the fine suggestions and comments!

--
Bill Davidsen <davidsen tmr com>
  "We have more to fear from the bungling of the incompetent than from
the machinations of the wicked."  - from Slashdot


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]