[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: f9 Preupgrade stalled?



On Sat, Nov 15, 2008 at 02:04:31PM -0700, Reid Rivenburgh wrote:
> On Sat, Nov 15, 2008 at 2:00 PM, Dave Feustel <dfeustel mindspring com> wrote:
> > I'm running preupgrade and it seems to have stalled.
> > The log follows. What do the advisories at the end mean?
> >
> > Thanks.
> > =================
> >
> > [root c2 ~]# preupgrade
> > Loaded plugins: refresh-packagekit
> > No package matched to remove
> > devhelp-0.21-2.fc10.i386 from anaconda-upgrade has depsolving problems
> >  --> Missing Dependency: gecko-libs = 1.9.0.2 is needed by package devhelp-0.21-2.fc10.i386 (anaconda-upgrade)
> > gnome-python2-gtkmozembed-2.19.1-23.fc10.i386 from anaconda-upgrade has depsolving problems
> >  --> Missing Dependency: gecko-libs = 1.9.0.2 is needed by package gnome-python2-gtkmozembed-2.19.1-23.fc10.i386 (anaconda-upgrade)
> > libkexiv2-0.1.7-1.fc9.i386 from installed has depsolving problems
> >  --> Missing Dependency: libexiv2.so.2 is needed by package libkexiv2-0.1.7-1.fc9.i386 (installed)
> > xulrunner-1.9.0.4-1.fc9.i386 from installed has depsolving problems
> >  --> Missing Dependency: libhunspell.so.1 is needed by package xulrunner-1.9.0.4-1.fc9.i386 (installed)
> > Traceback (most recent call last):
> >  File "/usr/share/preupgrade/preupgrade-gtk.py", line 198, in on_assistant_apply
> >    self._do_main()
> >  File "/usr/share/preupgrade/preupgrade-gtk.py", line 206, in _do_main
> >    self.main_preupgrade()
> >  File "/usr/share/preupgrade/preupgrade-gtk.py", line 349, in main_preupgrade
> >    self.pu.retrieve_treeinfo()
> >  File "/usr/lib/python2.5/site-packages/preupgrade/__init__.py", line 395, in retrieve_treeinfo
> >    self.instimage = cp.get('stage2', 'instimage')
> >  File "/usr/lib/python2.5/ConfigParser.py", line 520, in get
> >    raise NoOptionError(option, section)
> > ConfigParser.NoOptionError: No option 'instimage' in section: 'stage2'
> 
> I think the solution is to upgrade your preupgrade package.  I have
> this installed:
> 
> preupgrade-0.9.9-1.fc9.noarch
> 
> I'm now on F10 prerelease (whee!); it worked fine eventually.
> Basically, I think get the newer preupgrade package from updates or
> rawhide.

I tried running yum upgrade preupgrade but yum responded no packages
to upgrade.

Then I tried running preupgrade-cli Rawhide. This ran very fast but
ended with no error message but a traceback that looked like the
traceback that I got when I ran preupgrade (twice) in graphical mode.
Is there anything I should do differently?

Thanks.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]