[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: New FU9 x86-32 install on spare box, how to switch to kde?



On Sunday 23 November 2008, Paul W. Frields wrote:
>On Sun, Nov 23, 2008 at 05:45:31AM -0800, Antonio Olivares wrote:
>> --- On Sun, 11/23/08, Gene Heskett <gene heskett verizon net> wrote:
>> >2. I can't run yum cuz its already busy.  What's
>> >with that?
>>
>> as root su -
>> # rm /var/rum/yum.pid -f
>>
>> then yum will be free to run as you like.
>
>That's usually not a good idea.  The lock is probably being held by a
>temporary PackageKit process, and you should simply wait for it to
>complete.  If you can't stand to wait, find the PackageKit process and
>kill it.  Removing the resources yum uses to tell if there's a lock
>going is counterproductive since you'll probably get a different (and
>more head-scratching) error when you try to run a second copy.
>
>$ ps axw | grep '\(pk\|PackageKit\)'
>
>You'll probably need to be root to kill any back-side PackageKit stuff
>if it's running.  Again, it might be that a little patience will go a
>long way.  Remember you can tune PackageKit's timing using the System
>/ Preferences / System / Software Updates tool.

All no doubt excellent advice Paul, & thanks, unforch I didn't see it in time 
& was still a quart low on coffee.  So I'll ask a few more questions if you 
have the time.

Since the first reboot update it had requested had been done for a few hours, 
I just figured it was an old lock.  I did survey the output of 
system-config-services as root, where such a utility belongs and should be 
controllable from, without recognizing it, if indeed it was there.  In fact, 
the list it presented me with seemed to be pretty sparsely populated.

Has this "PackageKit" now replaced yum in FU9, and if so, do its abilities 
match or exceed that of yum/yumex with some of its plugins?

I also note that during the install, I told it to do the network manually at a 
fixed address because I do everything here behind an x86 install of dd-wrt, 
with host files for local dns, with gateway and resolv.conf pointed at the 
dd-wrt box.  On the reboot, it ignored all that, used dhcp and was assigned a 
network address by dd-wrt that made it impossible to find until I ran 
ifconfig to get its address.  Is that an artifact of NM?

If so, can I remove nm from FU9 without its deps taking 2/3rds of the system 
with it?

Plain old network has always worked how I want it to work here, and even with 
my lappy on the road, I have always had to get a radio from the motel and use 
the network & vim the configs to set it up as opposed to nm.  nm has never 
been able to actually turn the radio on once its been turned off, even after 
I've installed ndiswrapper, the drivers stolen from the residual ntfs 
filesystem I left when I installed f8 on the lappy, and had it working 
flawlessly here to an atheros card in the dd-wrt machine.  And of course, 
when I get back home with the lappy, then it doesn't work here anymore, and 
nm has left no trace of my old configs so I have to re-invent that wheel 
again.  TBT, its a hell of a lot easier to plug in a cat5 and forget the 
radio, so that is what I've been doing for the last 11 months.  At the F8 
level, nm is still a solution in search of a problem IMO.  Yeah, I know, the 
Old Fart Syndrome at work, but I don't really feel that I should be fixing 
something that wasn't broken in the first place.  Sigh...

Thanks Paul.

-- 
Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
QOTD:
	"It's a cold bowl of chili, when love don't work out."


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]