[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: New FU9 x86-32 install on spare box, how to switch to kde?



On Sun, Nov 23, 2008 at 01:33:47PM -0500, Gene Heskett wrote:
> I also note that during the install, I told it to do the network manually at a 
> fixed address because I do everything here behind an x86 install of dd-wrt, 
> with host files for local dns, with gateway and resolv.conf pointed at the 
> dd-wrt box.  On the reboot, it ignored all that, used dhcp and was assigned a 
> network address by dd-wrt that made it impossible to find until I ran 
> ifconfig to get its address.  Is that an artifact of NM?

If you want to use static networking, simply turn off NetworkManager
off by default using 'chkconfig'.  However, NetworkManager 0.7 seems
to have no problem with static networking here.  I am using it on
several Fedora 9 boxes at my house without a problem.

> If so, can I remove nm from FU9 without its deps taking 2/3rds of the system 
> with it?

There's no reason to remove it; that's what 'chkconfig' is for.

> Plain old network has always worked how I want it to work here, and even with 
> my lappy on the road, I have always had to get a radio from the motel and use 
> the network & vim the configs to set it up as opposed to nm.  nm has never 
> been able to actually turn the radio on once its been turned off, even after 
> I've installed ndiswrapper, the drivers stolen from the residual ntfs 
> filesystem I left when I installed f8 on the lappy, and had it working 
> flawlessly here to an atheros card in the dd-wrt machine.  And of course, 
> when I get back home with the lappy, then it doesn't work here anymore, and 
> nm has left no trace of my old configs so I have to re-invent that wheel 
> again.  TBT, its a hell of a lot easier to plug in a cat5 and forget the 
> radio, so that is what I've been doing for the last 11 months.  At the F8 
> level, nm is still a solution in search of a problem IMO.  Yeah, I know, the 
> Old Fart Syndrome at work, but I don't really feel that I should be fixing 
> something that wasn't broken in the first place.  Sigh...

NetworkManager has been respecting system-wide configurations for some
time now.... You've got about four or five issues combined in this
post that make it kind of difficult to advise well.

I've been using NetworkManager successfully for a couple of years now
in a number of different laptops so I know it's not fundamentally
broken.  You might want to try removing your user configurations
(located in ~/.gconf/system/networking/connections, backing them up
first!), setting your system's /etc/sysconfig/network-scripts/ifcfg-*
files to include 'NM_CONTROLLED=yes', and restart NM.

I have no idea if using ndiswrapper complicates things, but it
certainly doesn't make them easier.  I use wireless NICs that I know
are supportable by the Linux kernel drivers for best results.

HTH.

-- 
Paul W. Frields                                http://paul.frields.org/
  gpg fingerprint: 3DA6 A0AC 6D58 FEC4 0233  5906 ACDB C937 BD11 3717
  http://redhat.com/   -  -  -  -   http://pfrields.fedorapeople.org/
  irc.freenode.net: stickster @ #fedora-docs, #fedora-devel, #fredlug

Attachment: pgp3tbzAaiDfI.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]