[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F10-Beta - XF86VidModeQueryExtension has disappeared



On Tue, 18 Nov 2008 22:55:57 -0600
Frank Cox <theatre sasktel net> wrote:

> Something has changed recently and I'm not sure what package to file a bug
> against.
> 
> I use dosemu (http://www.dosemu.org) and it worked fine on my F10-beta laptop a
> few days ago.
> 
> Today I tried to run it and got this error:
> 
> /usr/bin/xdosemu: symbol lookup error: /usr/lib/dosemu/libplugin_X.so:
> undefined symbol: XF86VidModeQueryExtension 
> 
> XF86VidModeQueryExtension appears to be provided by libXxf86vm, but yum.log
> doesn't show any recent updates to that package.
> 
> So.. what actually broke here?

I've done some more investigation and am even more mystified.

I see this with "objdump -T libXxf86vm.so.1.0.0":

001027b0 g    DF .text	00000034  Base        XF86VidModeQueryExtension

So it's present and accounted for, but dosemu's libplugin_X.so apparently can't
find it.

I would think that since libXxf86vm.so.1.0.0 lives in /usr/lib, if there was
some sort of a pathing problem a lot more stuff would fail than just dosemu,
but so far that's the only thing that's not working.

What should I be looking at?



-- 
MELVILLE THEATRE ~ Melville Sask ~ http://www.melvilletheatre.com
DRY CLEANER BUSINESS FOR SALE ~ http://www.canadadrycleanerforsale.com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]