[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Grub can't mount drive (Solved)



g wrote:
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Paul Johnson wrote:

root partition are specified there.  If you post the grub.conf
settings for that kernel and the output from /sbin/fdisk, we might be
able to tell you if that's right.

'/sbin/fdisk -l' would be more informative.



peace out.

tc,hago.

g
.

****
in a free world without fences, who needs gates.

learn linux:
'Rute User's Tutorial and Exposition'   http://rute.2038bug.com/index.html.gz
'The Linux Documentation Project'   http://www.tldp.org/
'LDP HOWTO-index'   http://www.tldp.org/HOWTO/HOWTO-INDEX/index.html
'HowtoForge'   http://howtoforge.com/

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (GNU/Linux)
Comment: Using GnuPG with Red Hat - http://enigmail.mozdev.org

iD8DBQFJKg30+C4Bj9Rkw/wRAvF0AJwK1d2fxfUoisMhjBdGFZ48tRTQtwCfZIN6
gURDoDacVo309In7puZumq4=
=AFDh
-----END PGP SIGNATURE-----

I was able to solve this problem by following these steps:

I downloaded and burned a Super GRUB disk and booted the computer with it. This allowed me to attempt an auto fix but that did not help. So I used it to look at all my hard drives and their partitions.
I then rebooted into rescue mode using the Fedora CD.
At command prompt I typed the following:
chroot /mnt/sysimage
grub-install /dev/sda  (/dev/hda for IDE drives)

After reboot I was able to get the GRUB OS list but still could not boot Fedora.
I then highlighted the Fedora OS I wanted to boot and pressed "e"
It then showed me that the root partition was (hd1,2) but my Fedora partition is on (hd1,1)
I highlighted the root selection and pressed "e"
I was then able to change the root to (hd1,1) and booted Fedora successfully. After a successful boot up and login, I used krusader in root mode and went to /boot/grub/ and edited the grub.conf file so that all root entries were (hd1,1) (This can also be done through the command line in root mode)
Problem solved.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]