[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

F10 system-config-services does not respond when enabling or disabling a service



when i try to use system-config-services to enable a service it does not respond.

I am running KDE 4.1.3 on Fedora 10. this worked with no problems on F9. I was logged on as root.

i ran it from terminal and got the following error message:

Traceback (most recent call last):
File "/usr/sbin/system-config-services", line 795, in on_serviceEnable_activate
    service.enable ()
File "/usr/lib/python2.5/site-packages/slip/dbus/polkit.py", line 48, in enable_proxy_wrapper
    return func (*p, **k)
File "/usr/lib/python2.5/site-packages/scservices/dbus/proxy/services.py", line 64, in enable self.dbus_object.enable (dbus_interface = "org.fedoraproject.Config.Services.ChkconfigService") File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
File "/usr/lib/python2.5/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.fedoraproject.slip.dbus.service.PolKit.NotAuthorizedException.org.fedoraproject.config.services.manage:

as a workaround I used chkconfig to set things the way i wanted, however I thought someone might want to look at it. just in case.

Thanks.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]