[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

key mapping problem



Hi all,

I upgraded my Acer-Aspire-1700 Laptop from F9->F10
After that I got problems with the key-mapping

I use xmodmap to "redefine" some keys. This worked perfectly in F9 but after
the upgrade some keys (i.e. "left_arrow) is not working, when typed on the
laptop's own keyboard. On a attached USB-keyboard everything is fine.
Removing the xmodmap-table make at least the "arrow" keys work again.

If I check with the program "xkeycaps" which keycodes are generated I see
that on the laptops-keyboard the "left_arrow" generates code 71 instead of 64,
which explains why xmodmap fails because keycode 71 (right-ctrl) is redefined. 

A few other keys show the same strange behaviour

Can anybody explain this?

                 Jouk
		 


Pecunia olet!

>------------------------------------------------------------------------------<

  Jouk Jansen
		 
  joukj hrem nano tudelft nl

  Technische Universiteit Delft        tttttttttt  uu     uu  ddddddd
  Kavli Institute of Nanoscience       tttttttttt  uu     uu  dd    dd
  Nationaal centrum voor HREM              tt      uu     uu  dd     dd
  Lorentzweg 1                             tt      uu     uu  dd     dd
  2628 CJ Delft                            tt      uu     uu  dd     dd
  Nederland                                tt      uu     uu  dd    dd
  tel. 31-15-2782272                       tt       uuuuuuu   ddddddd

>------------------------------------------------------------------------------<


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]