[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Yum F9 --> F10, still old F9 packages



On Sun, Nov 30, 2008 at 1:10 PM, Colin Brace <cb lim nl> wrote:
>
> Hi all,
>
> For reasons I don't entirely understand, neither preupgrade nor the DVD
> worked for me, so I ended up upgrading from F9 to F10 by means of yum.

Preupgrade worked for me on three out of three systems I've upgraded
so far. So you must have something different that is tripping it up.
It is very likely those stubborn packages you refer too.

> Now I have enabled the rpmfusion repos, but I can't upgrade the relevent
> packages from that repo as there is a dependency problem with the F9 version
> of avidemux installed: an older x264 library. When I try to delete avidemux
> using RPM, the latter hangs every time, and I have to kill it in a second
> terminal.
>
> Any tricks for getting rid of stubborn old packages?
>
> The command 'package-cleanup --orphans' (from yum utils) indicates there are
> a couple hundred fc9 packages still on my system, but doesn't offer a way of
> removing them. Is there some other way of getting rid of them in one
> operation?

I am seeing the fc9 packages, but based on previous discussions, I
believe it is (mostly) intentional. It is my understanding that if the
package doesn't change between F9 and F10, they don't bother
rebuilding the package if they don't have to. So it may be dangerous
to indiscriminately remove every fc9 package.

That reason likely doesn't cover all the fc9 packages on your systems
still. There are a few other reasons I can think of:
1) The packages are for applications that no longer built for F10.
Sometimes these unmaintained apps are worth keeping around if you need
them. Often times there is a new substitute for them that doesn't
strictly obsolete them.
2) Removal of the packages were blocked by a script error. I've had
that happen for an old fc7 version of avahi and had to use the
--noscripts option in rpm to remove it because it was blocking a 'yum
update'.

What I am trying to think of is a combination of repoquery/grep/diff
commands that will give me a list of all the packages on my system
that are not contained in the repos. That would at least separate out
the legitimate fc9 packages from the cruft.

> Also, w.r.t rpmfusion, yum keeps quitting with an error message some but not
> all of the time:
>
> "Error: Cannot find a valid baseurl for repo: rpmfusion-free"
>
> Anyone else seeing this?

No ... could be a temporary Internet connectivity thing. But I would
try reinstalling these two packages:
rpmfusion-free-release.noarch                    10-1
rpmfusion-nonfree-release.noarch                 10-1

/Mike


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]