[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Preupgrade on Fedora-7



Timothy Murphy wrote:
I just resurrected an old computer running Fedora-7.
I ran "yum update" and it successfully updated 420 packages,
amounting to 850MB.
But when I yum-installed preupgrade, and then ran preupgrade,
I got the error:
-----------------------------------------------------
[tim harriet yum.repos.d]$ sudo preupgrade
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 19, in <module>
    import gtk
  File "/usr/lib/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 76, in <module>
    _init()
  File "/usr/lib/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 64, in _init
    _gtk.init_check()
RuntimeError: could not open display
-----------------------------------------------------

I didn't really expect preupgrade to upgrade this machine to Fedora-10;
but why is it offered if it doesn't work?



Are you running as root? Does root have access to your X-server to open windows? (Is X11 even running?) the "$" prompt indicates that you are running as a user.

What does running "pre-upgrade-cli" do when run from a root account?

I tried this earlier (before F10 was released) and all attempts failed due to conflicts.

--
Kevin J. Cummings
kjchome rcn com
cummings kjchome homeip net
cummings kjc386 framingham ma us
Registered Linux User #1232 (http://counter.li.org)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]