[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Slow Grub on new mobo Q



On Wed, Oct 1, 2008 at 9:50 PM, Gene Heskett <gene heskett verizon net> wrote:
> On Thursday 02 October 2008, Kam Leo wrote:
>>On Wed, Oct 1, 2008 at 8:14 PM, Gene Heskett <gene heskett verizon net>
> wrote:
>>> On Wednesday 01 October 2008, Kam Leo wrote:
>>>>On Wed, Oct 1, 2008 at 11:13 AM, Gene Heskett <gene heskett verizon net>
>>>
>>> wrote:
>>>>> Greetings;
>>>>>
>>>>> I built a new box yesterday, and one of the things I'm seeing is about a
>>>>> 10 second lag between the bios clearing the screen after doing its
>>>>> thing, and the "Loading Grub stage 2", which stays on screen for several
>>>>> seconds, then its blanked for another 10 secs or so, and finally the
>>>>> grub 'choice' menu comes up.
>>>>>
>>>>> This is with the new grub.  One thing I had done on the previous mobo
>>>>> was to have just one entry in /boot/grub/devices, but I see that has
>>>>> been reset by something from /dev/sdb to /dev/sda, presumably by
>>>>> upgrading grub this morning.
>>>>>
>>>>> The bios is set to boot from the first ide, which is (hd0,0) I believe.
>>>>>
>>>>> What can I post that might be of interest?, just ask.
>>>>>
>>>>> Thanks.
>>>>>
>>>>> --
>>>>> Cheers, Gene
>>>>
>>>>What new grub? As far as I am aware there has been no update to grub.
>>>
>>> The one that's been sitting in updates for 2-3 months, scared to install
>>> it because my drive mapping was fubar on that biostar mobo with its
>>> outboard sata controller.  Now on this asus, it seems like hd0,0 is indeed
>>> /dev/sda1, aka /boot in the label.  Anyway, it worked.
>>>
>>> --
>>> Cheers, Gene
>>
>>Why didn't you state that you were running F8?  If it makes you feel
>>any better here is the changelog for grub-0.97-33.1-fc8:
>
> I thought I did at first, but CRS could make a liar out of me.  Sorry.
>
>>Changelog
>>
>>* Thu May 29 2008 Peter Jones <pjones redhat com> - 0.97-33.1
>>  - Backport F-9's grub to F-8.
>>* Tue Apr 08 2008 Peter Jones <pjones redhat com> - 0.97-33
>>  - Rewrite ia32 efi call wrapper to make the makefile simpler.
>>
>>F9's grub is at 0.97-33. The previous version for F8 was 0.97-33.
>
> That is the same numbers.  Typu?
>
>>Unless Peter Jones made some dramatic changes I don't see how this
>>backporting is going to adversely affect your system.
>
> Thanks.  But this still does not explain why grub itself is so slow.
>
> After the bios is done, then the next thing one normally sees is the "Grub
> stage 2 loading", but I'm watching a monitor telling me there is no input
> drive for about 12 seconds between the bios clearing the screen, and that
> printout.
>
> And normally that just sort of flickers for a few milliseconds, but that now
> stays on screen for 2 or 3 seconds, then the screen is cleared again, and
> about 10 seconds later the boot choice menu finally pops up.  This only took
> maybe 2 seconds total on the old motherboard, now it's a good 20-25 seconds
> from the bios clearing the screen to the boot selection menu.
>
> Its that time that I'm fussing about.
>
> --
> Cheers, Gene

Have you checked the boot order in your BIOS settings? Also do you
happen to have non-bootable media in your CD/DVD drive?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]