[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: playing mpeg has cone screwey.



On Friday 03 October 2008 19:59, Aaron Konstam wrote:
> On Fri, 2008-10-03 at 11:53 +0930, Tim wrote:
> > Aaron Konstam:
> > >> When I try to play a mpeg file(.mpg) in Firefox instead of getting
> >
> > video
> >
> > >> I get a window telling me I am trying to use proprietary formats
> >
> > for
> >
> > >> which I need codecs to run under Fedora. The available codecs cost
> > >> money.
> >
> > Peter Langfelder:
> > > I'm not sure I can help you directly, but when I updated Firefox the
> > > other day, the update changed the status of some of the plugins (it
> > > activated a few I did not want). One of the plugins that became
> >
> > active
> >
> > > was the media plugin for playing movies, and it does complain about
> > > missing codecs.
> >
> > Perhaps the Totem plugin?  Totem (the thing listed, *stupidly*, as
> > just
> > "Movie Player" in the Gnome Menus) will give a similar warning when
> > you
> > try to play encumbered files.  I've got more than one plugin
> > installed,
> > and it's been working fine, but I haven't recently tried doing the
> > sort
> > of thing the original poster had fail on them.
>
> Well two things. Playing mpeg video in Firefox worked up to last week.
> Now it doesn't. So it must be an update that fouled things up.
> Second , I have a perfect record. Fedora totem has never worked for me
> ever. Previously to get totem to work I had to install totem-xine from
> livna. And that what works on my F8 machine. Totem currently does not
> work on my F9 machine. Changing to vlc made things work. Further,
> totem-xine no longer exists at livna.
>
> It is hard to believe that no one else has noticed this. Why don't you
> try it and see whether it works now for you. I have never before seen
> this propriety format message.


Hi Aaron. I've had F9 installed for a while, but not being too impressed with 
KDE4, havn't done much with it, apart from getting updates.

Today, after doing the updates, and seeing someone with a Firefox problem on 
another list, I fired up Firefox on F9. Now I havn't installed any plugins 
for Firefox, so those that are there, are those that were installed in 
Firefox when I installed F9.

Now I go to http://www.bloomberg.com . The site opens ok, so so far so good,  
I click on radio on the page, and get a window with a load of legal stuff, as 
to why I can't listen to the radio. A button on this page now opens another 
window saying that I can buy codecs so that I can listen to the radio (28€). 
Now I try another site http://cpr.org/ , which also streams with the .asx 
format. Same thing again. Pay for the codecs, and you can hear the sounds.

Now there were a whole bunch of problems when the Fedora servers were 
compromised, and I'd disabled the livna repo. Now that things have settled 
down, I re-enable the Livna repo. I'm using Apt, not Yum, but installing the 
following package, and it's deps should work on both.

apt-get install gecko-mediaplayer
or
yum install gecko-mediaplayer

having installed the gecko-mediaplayer package, and it's deps, I now get audio 
streams from http://cpr.org/ , and no longer a request to pay for codecs. The 
bloomberg site still won't play, but that's an ongoing problem.

For what it's worth Totem appears to be the problem. It tries to grab first 
place when you access a site with Firefox, then says it doesn't know how to 
handle the media, or in my experience on F9, has the audacity to ask for 
money so that I can hear the sounds.

Nigel.




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]