[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: More RAID-1 problems



Jeffrey Ross wrote:

Just thought I'd post a follow-up, the problem has been solved and I learned something new in the process.

I extracted the files from the initrd file but didn't realize that a copy of the mdadm.conf file is stored there as well. Sometime between the last two kernel updates I had modified the /etc/mdadm.conf file with incorrect settings for the arrays, I had then installed a new kernel update which picked up my bad /etc/mdadm.conf file and inserted it into the initrd. Once I learned that a copy of the conf file is stored in the initrd it was a simple process to manually adjust the initrc file with the correct file.
Problem solved!

Only remaining question, if I should adjust the /etc/mdadm.conf file again how can I get the initrc file to update without having to manually uncompress and extract the cpio archive and then re-archive and re-compress it by hand?

I thought /etc/mdadm.conf wasn't really necessary anymore - and you said the rescue mode boot worked when it obviously couldn't read it. What happens if you just remove it?

--
  Les Mikesell
   lesmikesell gmail com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]