[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Can't remove old avahi package



I've got a frustrating little problem. I'm trying to update my system and one package (avahi-autoipd) can't install because of conflicting packages from avahi-0.6.17-1.i386.fc7.

However, I"ve got the F9 version installed, so that's not a problem. What /is/ a problem is that I cannot remove that package. rpm -e bombs with this:

[markh sulla ~]$ sudo rpm -e avahi-0.6.17-1.fc7.i386
error: %postun(avahi-0.6.17-1.fc7.i386) scriptlet failed, exit status 1


And yum remove /says/ it's removed, but it's not:

Transaction Test Succeeded
Running Transaction
 Erasing        : avahi                                             [1/1]

Removed: avahi.i386 0:0.6.17-1.fc7
Complete!
[markh sulla ~]$ sudo rpm -qa | grep avahi
kdnssd-avahi-devel-0.1.3-0.6.20080116svn.fc9.i386
avahi-glib-0.6.22-10.fc9.i386
avahi-devel-0.6.22-10.fc9.i386
avahi-0.6.22-10.fc9.i386
avahi-qt3-0.6.22-10.fc9.i386
avahi-compat-libdns_sd-0.6.22-10.fc9.i386
kdnssd-avahi-0.1.3-0.6.20080116svn.fc9.i386
avahi-0.6.17-1.fc7.i386


So, I can't update that package because of this. I could probably remove avahi altogether to see if that fixes this, but if I do it removes GNOME almost completely. What can I do to get this package gone without major surgery to my system?




--
Mark Haney
mhaney ercbroadband org
Fedora release 9 (Sulphur)
Kernel: 2.6.25.10-86.fc9.i686 GNU/Linux

16:31:50 up 3 days,  6:20,  2 users,  load average: 0.96, -0.6.7-17.10.77, 0.85




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]