[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: fedora upgrade from 8->>9



On Wed, 8 Oct 2008 22:01:02 -0700, bruce wrote:

> Hi.
> 
> I'm doing an upgrade from fedora 8 to 9, following the instructions listed
> in fedoraproject.org.
> 
> However, I'm running into an issue where I have some sort of issue with HAL.
> As a test, I'm simply trying to upgrade hal, and then i'll do a "yum
> upgrade" for everything.
> 
> the repos dir is:
> [root toshiba yum.repos.d]# ls
> fedora-development.repo_     fedora-updates-testing-newkey.repo
> fedora-rawhide.repo          fedora-updates-testing.repo_
> fedora.repo_                 fedora-updates-testing.repo__
> fedora.repo__                fedora-updates-testing.repo__2
> fedora-updates-newkey.repo   livna-devel.repo__
> fedora-updates-newkey.repo~  livna.repo_
> fedora-updates.repo~         livna-testing.repo__
> fedora-updates.repo_         remi-fedora.repo
> fedora-updates.repo.rpmnew

Ouch! Please run "yum repolist" instead, as your list of files is a mess.

Also ensure that the enabled repositories really point to Fedora 9.
You need at least these repos:
  fedora
  updates-newkey

> --> Processing Dependency: hal-libs = 0.5.10-4.fc8 for package: hal
> ---> Package hal-libs.i386 0:0.5.11-2.fc9 set to be updated
> ---> Package PolicyKit.i386 0:0.8-3.fc9 set to be updated
> --> Processing Dependency: hal-libs = 0.5.10-4.fc8 for package: hal
> --> Finished Dependency Resolution
> hal-0.5.11-2.fc9.x86_64 from updates-newkey has depsolving problems
>   --> Missing Dependency: libsmbios.so.2()(64bit) is needed by package

Looks like you need to enable the Fedora 9 "Everything" repository.
It's called [fedora] in "fedora.repo".


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]