[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: DHCP will not grab ip.

Dave Feustel wrote:
On Thu, Oct 09, 2008 at 12:32:49PM -0400, Bill Davidsen wrote:
Dave Feustel wrote:
On Wed, Oct 08, 2008 at 10:20:17PM +0100, Laura Speck wrote:
I have F9 running on a computer with just one nic. Everything worked
until about a week ago, when the nic suddenly no longer automatically
got a dhcp address. My work around is to run dhclient etho &. DHCP
connects then. I still haven't figured out why this happened or what
the correct fix is.

I had a thread going about the recent "enhancement" to NetworkManager. After applying that both my hardwire and wireless NICs stopped working. Did you by any chance "upgrade" your packages recently, say about the time everything stopped working? Mine worked after the upgrade until the next reboot, then went away forever. I tried to force a downgrade, but rpm was designed to work in one direction only, there's no way to tell rpm or yum to roll back and rollback all the dependencies at the same time.

Unfortunately, I don't remember any details except that, as you noted,
no network connection was established at system powerup one morning.

I gave up, I removed NM totally and completely, and now do the whole setup with a script run at boot time.

All I have do to get connectivity is run dhclient as root.

Interesting. I run iwconfig to set the essid, channel, and key. Then dhclient. Previously NM had all the info except the channel, and figured that out in "Managed" mode. After it stopped working I tried "Ad-hic" as well, so I could set the channel. Made no difference.

Bill Davidsen <davidsen tmr com>
  "We have more to fear from the bungling of the incompetent than from
the machinations of the wicked."  - from Slashdot

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]