[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: DHCP will not grab ip.



Bill Davidsen wrote:
> Dave Feustel wrote:
>>> I gave up, I removed NM totally and completely, and now do the whole
>>> setup with a script run at boot time.
>>
>> All I have do to get connectivity is run dhclient as root.
>>
In the past, I have configured the wireless interface for use with
the network service. You just add the information to the ifconfig
file for the interface. (And change your service configuration so
network runs instead of Network Manager.)

> Interesting. I run iwconfig to set the essid, channel, and key. Then
> dhclient. Previously NM had all the info except the channel, and figured
> that out in "Managed" mode. After it stopped working I tried "Ad-hic" as
> well, so I could set the channel. Made no difference.

One thing that may make a difference is to add restricted to the key
setting string.

iwconfig wlan0 key restricted <key>

I know with the way I have my router configured, you can not get an
IP address unless you have the key and the restricted option. (Now
if only some of the things connected were not limited to WEP so I
could convert it to WPA.)

Mikkel
-- 

  Do not meddle in the affairs of dragons,
for thou art crunchy and taste good with Ketchup!

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]