[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: atheros madwifi driver not working



Tried installing the F10 kernel (using yum with rawhide repo enabled)
and apparently it doesn't work with F9. Hangs at "creating initial
device nodes". :-(

2008/10/10 Jim <mickeyboa sbcglobal net>:
> Martín Marqués wrote:
>>
>> I just got a Compaq Presario F700 which has an Atheros chip based wifi
>> PCI express card. I check on the web and found that I had to install
>> madwifi-hal.
>>
>> I can't find that package in livna, nor can I find it in atrpms, so I
>> installed kmod-madwifi and madwifi from livna (which installed for
>> dependencies iwl4965-firmware), but even though the module gets loaded
>> automatically, the card doesn't work.
>>
>> What's wrong?
>>
>> Info:
>>
>> # lsmod | grep ath
>> ath_pci               235072  0
>> wlan                  219376  1 ath_pci
>> ath_hal               282240  1 ath_pci
>>
>> # lspci -vv
>> 03:00.0 Ethernet controller: Atheros Communications Inc. AR242x
>> 802.11abg Wireless PCI Express Adapter (rev 01)
>>        Subsystem: Hewlett-Packard Company Unknown device 137b
>>        Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop-
>> ParErr- Stepping- SERR- FastB2B- DisINTx-
>>        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort-
>> <TAbort- <MAbort- >SERR- <PERR- INTx-
>>        Interrupt: pin A routed to IRQ 19
>>        Region 0: Memory at f6000000 (64-bit, non-prefetchable)
>> [disabled] [size=64K]
>>        Capabilities: [40] Power Management version 2
>>                Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA
>> PME(D0-,D1-,D2-,D3hot-,D3cold-)
>>                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
>>        Capabilities: [50] Message Signalled Interrupts: Mask- 64bit-
>> Queue=0/0 Enable-
>>                Address: 00000000  Data: 0000
>>        Capabilities: [60] Express (v1) Legacy Endpoint, MSI 00
>>                DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s
>> <512ns, L1 <64us
>>                        ExtTag- AttnBtn- AttnInd- PwrInd- RBE- FLReset-
>>                DevCtl: Report errors: Correctable- Non-Fatal- Fatal-
>> Unsupported-
>>                        RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
>>                        MaxPayload 128 bytes, MaxReadReq 512 bytes
>>                DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq-
>> AuxPwr- TransPend-
>>                LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1,
>> Latency L0 <512ns, L1 <64us
>>                        ClockPM- Suprise- LLActRep- BwNot-
>>                LnkCtl: ASPM Disabled; RCB 128 bytes Disabled- Retrain-
>> CommClk-
>>                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
>>                LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train-
>> SlotClk+ DLActive- BWMgmt- ABWMgmt-
>>        Capabilities: [90] MSI-X: Enable- Mask- TabSize=1
>>                Vector table: BAR=0 offset=00000000
>>                PBA: BAR=0 offset=00000000
>>        Capabilities: [100] Advanced Error Reporting <?>
>>        Capabilities: [140] Virtual Channel <?>
>>        Kernel modules: ath5k, ath_pci
>>
>>
>
> FC10 has the kernel-2.6.27 that has drivers for this Wifi card, you won't
> find any help in the 2.6.26.
> the livna driver doesn't work right.
> I have the eeePC 702 that uses FC 10 2.6.27 and the Atheros Ar5007EG WIFI
> works perfect.
>
> --
> fedora-list mailing list
> fedora-list redhat com
> To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
> Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines
>



-- 
Martín Marqués
select 'martin.marques' || '@' || 'gmail.com'
DBA, Programador, Administrador


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]