[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ftp problem



On Sun, Oct 12, 2008 at 4:10 PM, Gerhard Magnus <magnus agora rdrop com> wrote:
> I'm running FC9 on a small LAN that also has some Windows machines. I'd
> like to use one of the linux boxes as an FTP server so that the Windows
> systems can access a directory on that server. None of this has been
> opened to the world outside by opening port 21 on the router -- it's
> strictly "in house." Eventually I'll learn Apache, but FTP looks much
> simpler for what I'd like to do. (Or so I thought :) Here's what I've
> done, following instructions in www.fedoraguide.info:
>
> (1) installed proftpd on the server
> (2) added these lines to the end of the /etc/proftpd.conf file:
>
> <Anonymous /home/magnusg/music/>
>  User            ftp
>  Group            nogroup
>  UserAlias          anonymous ftp
>  DirFakeUser on ftp
>  DirFakeGroup on ftp
>  RequireValidShell      off
>  MaxClients         10
>  DisplayLogin        welcome.msg
>  DisplayFirstChdir      .message
>  <Directory *>
>  <Limit WRITE>
>   DenyAll
>  </Limit>
>  </Directory>
> </Anonymous>
>
> (3) on the server, used system-config-services to enable proftpd on run
> levels 3 and 5
> (4) /etc/init.d/proftpd restart
> (5) on the server, used system-config-firewall to make FTP (with
> Port/Protocol = 21/tcp) a trusted service
> (6) the permissions for the ftp directory look like this:
>
> drwxrwxr-x 17 magnusg magnusg  4096 2008-09-14 18:29 music
>
> But when I try using filezilla from a Windows box, logging in as
> anonymous of port 21, I get these messages:
>
> 220 FTP server ready
> 331 anonymous logon OK...
> 530 unable to set anonymous privileges
> 530 login incorrect
>
> So I seem to be connecting, but not much else. Googling the error
> message leads to others who've had similar problems but (at least so
> far) no one with a solution.... Thanks for any tips on how to proceed.
>
> Jerry
>
> --
> fedora-list mailing list
> fedora-list redhat com
> To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
> Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines
>

Hi Jerry!

Only some guesses here:

1. Try removing:

<Directory *>
  <Limit WRITE>
   DenyAll
  </Limit>
 </Directory>

>From your /etc/proftpd.conf file.  Then it should match what is mentioned here:

http://www.fedoraguide.info/index.php?title=Main_Page#How_to_install_FTP_Server_for_File_Transfer_service

Under " How to configure FTP Server to allow anonymous FTP user to read/write".

If still no joy try turning off SELinux for a session.

If still no joy make sure you have a user "anonymous" and that they
are part of the "magnusg" privileged group.

Good Hunting!

Tod


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]