[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Can't remove old RPM



FC8-i386.
I upgraded from FC7 to FC8 and now I have got problems with old rpm avahi-0.6.17-1.fc7.i386 , below is the attempt to remove . I can't upgrade because of the old rpm.

When I did a  rpm -qa | grep avahi , both avahi rpms showed up:
avahi-3-0.6.21-8.fc8
avahi-0.6.17-1.fc7.i386.

I did a rpm -e --nodeps --allmatches avahi and removed avahi-3-0.6.21-8.fc8, but it wouldn't get rid of avahi-0.6.17-1.fc7.i386.

[root x86_64 mickey]# rpm -e --nodeps avahi
error reading information on service avahi-dnsconfd: No such file or directory
error: %preun(avahi-0.6.17-1.fc7.i386) scriptlet failed, exit status 1

So how do I get rid avahi-0.6.17-1.fc7.i386 that supposedly not even installed.

Is there a yum command that I could also use, that would let you use the comparable --nodeps command


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]