[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Can't remove old RPM



Jim wrote:
Patrick O'Callaghan wrote:
On Tue, 2008-10-14 at 18:39 -0400, Jim wrote:
So how do I get rid avahi-0.6.17-1.fc7.i386 that supposedly not even installed.

        rpm -q avahi-0.6.17-1.fc7.i386

to see if it's there, then

        rpm -e avahi-0.6.17-1.fc7.i386

If your RPM database is corrupt, you might want to do "rpm --rebuilddb".

poc

I did a below, but had to do a --nodeps to prevent from losing many packages and lockup my box.

# rpm -e --nodeps avahi-0.6.17-1.fc7.i386
error reading information on service avahi-dnsconfd: No such file or directory
error: %preun(avahi-0.6.17-1.fc7.i386) scriptlet failed, exit status 1


use --noscripts

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]