[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F9: Firefox: Java based site fails to work.



Claude Jones wrote:

On Sun October 19 2008 12:12:35 am Matthew Flaschen wrote:

> Dan Thurman wrote:

> >> plus, once you have it installed, you can make 'relaycall.com' perminate

> >> to load every time.

> >

> > I installed noscript, then allowed 'relaycall.com' and IP address:

> > '12.x.x.x'

>

> NoScript is not going to help you get Java working. g should have been

> more clear about that. I would recommend uninstalling it at least until

> you solve your original problem.

>

> As Nigel noted, you will probably have to install Sun Java in order to

> use your site. There are many tutorials specifically about this, such

> as

> http://www.ilovetux.com/2008/05/fedora-9-sun-java-on-fedora-9-install.html

> .

>

> Matt Flaschen

I hope this question is related to the discussion, sufficiently. Since it pertains to switching from gcj to sun java, I think it does. I found several problems with that page you link to, and solved them, but, I'm not sure if what I did was correct. First, the version numbers included in the various commands have to be adjusted since the actual version you download from the site has progressed beyond the one that's used in the suggested commands - that's fairly trivial, but needs to be pointed out. Once I sorted that out, I could not find an elegant way to turn off gcj; my first inclination was to remove it, but, that led to a request to delete about 25 other packages from my machine for dependencies - I stopped that. Then I tried to remove the plug-in from Mozilla - creating the linked file to the java, as suggested by one of the commands on that linked page, had already produced a message that the file existed, so I suppose that libjavaplugin_oji.so was being used by gcj; I renamed that file and then ran the link command again - that appeared to be successful and produced the appearance of Sun Java in the plug-in list in Firefox; but, the gcj plug-in was still there, and attempts to use the ATT Relay site continued to fail; then I renamed a second plug-in in the mozilla plug-in folder called libjavaplugin.so - that didn't work, because it was simply a link to another *.so file somewhere I suppose, so gcj continued to appear in my plug-in list in Firefox - finally, I just created a folder inside the Mozilla plug-in folder called 'old' and moved the now renamed files 'libjavaplugin_oji.so.gcj' and 'libjavaplugin.so.gcj' to this folder, and that finally solved the problem. Now, the only java that appears in my Firefox plug-in list is the one from Sun, and the ATT Relay site works perfectly.

So, my question is, was there some better way of accomplishing this end? If not, this is not what one could call a simple solution, and that page you linked to will definitely NOT get the desired result without a lot of hacking. I'm betting I came up with a kludge, and there must be a better way.

--

Claude Jones

Brunswick, MD

Gawd.  What a tough nut to crack, but I got it.

The relaycall.com site does not work with F9's OpenJdk, at least for me.

But after installing Sun's Java and configuring the /etc/alternatives using
galternatives, I was able to get this site working now.

1) You do not need to create the libjavaplugin_oji.so in /usr/lib/mozilla/plugin directory as I have tested this. Use galternatives to set this link (libjavaplugin.so) to Sun's plugin
   and the link is updated properly in /etc/alternatives directory.

2) After you have installed Sun's Java, you still need to make sure
that the /etc/alternatives contains information to Sun's Java installation.
  To do that, use the nifty tool: galternatives:

   1) run: galternatives

   2) Click on left pane: java
If: /usr/java/jrel1.6.0_07/bin/java on right pane is not there, then Click; Add, then Browse, and add the path in. You can set the priority as desired. Be sure to click the radio-button on the correct version you want to use!

   3) Click on left pane: libjavaplugin.so
If: /usr/java/jrel1.6.0_07/plugin/i386/ns7/libjavaplugin_oji.so on the right pane is not there, then Click: Add, then Browse, and add the path in. You can set the priority as desired. Be sure to click the radio-button on the correct version you want to use!

4) After configuring as above, you need to restart FF since the changes are not
       dynamically updated within FF.

Cheers,
Dan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]