[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: fc8 mysql libs brocken ??





On Tue, Oct 21, 2008 at 3:35 AM, Gregory Machin <gdm linuxpro co za> wrote:
On Mon, Oct 20, 2008 at 11:25 PM, David Timms <dtimms iinet net au> wrote:
> Gregory Machin wrote:
>>
>> Hi
>> I'm having a lot of trouble getting application with mysql
>> dependencies to compile, all the errors are the same with the make
>> "
>> /usr/bin/ld: skipping incompatible /usr/lib/mysql/libmysqlclient.so
>> when searching for -lmysqlclient
>
> Don't know the answer, but to start off:
> - where does that file come from ?
> rpm -qf /usr/lib/mysql/libmysqlclient.so

Here are my results
mysql-devel-5.0.45-6.fc8

>
> - what mysql related packages do you have installed ?
> rpm -qa|grep -i sql|sort

hsqldb-1.8.0.8-1jpp.4.fc8
libdbi-dbd-mysql-0.8.2-1.2.fc8
libdbi-dbd-pgsql-0.8.2-1.2.fc8
mod_auth_mysql-3.0.0-5
mod_auth_pgsql-2.0.3-6
mono-data-sqlite-1.2.4-2.fc8
mysql-5.0.45-6.fc8
mysql-connector-java-3.1.12-3.fc6
mysql-connector-odbc-3.51.14r248-2.fc8
mysql-devel-5.0.45-6.fc8
mysql-devel-5.0.45-6.fc8
mysql-libs-5.0.45-6.fc8
mysql-libs-5.0.45-6.fc8
MySQL-python-1.2.2-4.fc8
mysql-server-5.0.45-6.fc8
perl-DBD-MySQL-4.005-2.fc8.1
php-mysql-5.2.4-3
php-pgsql-5.2.4-3
postgresql-8.2.5-1.fc8
postgresql-libs-8.2.5-1.fc8
postgresql-libs-8.2.5-1.fc8
postgresql-python-8.2.5-1.fc8
postgresql-server-8.2.5-1.fc8
sqlite-3.4.2-3.fc8
sqlite-3.4.2-3.fc8
sqlite-devel-3.4.2-3.fc8
sqlite-devel-3.4.2-3.fc8





Is your F8 a 32 or 64 bits?


--
Paulo Roma Cavalcanti
LCG - UFRJ

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]