[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F8 dependency hell with avahi



Beartooth wrote:
I'm running F8 on a T30 thinkpad. Whenever I try to do yum update, I get :

=====		=====		=====		=====
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /etc/avahi/avahi-autoipd.action from install of avahi-
autoipd-0.6.21-8.fc8.i386 conflicts with file from package avahi-0.6.17-1.fc7.i386
  file /usr/sbin/avahi-autoipd from install of avahi-
autoipd-0.6.21-8.fc8.i386 conflicts with file from package avahi-0.6.17-1.fc7.i386

Error Summary
-------------
	=====		=====		=====		=====

I've tried everything I can think of to update or get rid of that avahi-0.6.17-1.fc7.i386 with the "fc7" in it, and nothing I know works. Pirut did claim to have removed it; but yum update still failed the same.

What do I do, while I still can? Yum wants to change 124 packages, including replacing a kernel.


Do a  rpm -q avahi-autoipd.action  , see if it's installed

Also do a rpm -qa | grep avahi , and check for duplicate packages of same name.

I had this same problem with avahi last week.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]