[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Libraries disappearing from compat-libstdc++-296

Kevin Kofler wrote:
Gordon Messmer <yinyang <at> eburg.com> writes:
...which seems odd. I can't see how the compat-libstdc++-296 package actually provides compatibility with binaries that were built with gcc 2.96.

It does. libstdc++-libc6.2-2.so.3 is the version which actually shipped with GCC 2.96. (At least the RH one. There was no formal 2.96 release, so other distributions may have been shipping other 2.96 variants with different libraries.)

The missing libstdc++-libc6.1-1.so.2 is actually from GCC 2.95 (or EGCS, which was the project which lead to GCC 2.95 and used the same soname).

Upstreams still building their binaries with GCC 2.95 (or 2.96 for that matter) should really be told to get with the times. GCC is at 4.3 now, 2.95 is just a long gone memory from the distant past.

Unfortunately people and companies who have critical commercial software for which upgrades are unavailable or unafordable remember those days well. I have FC4 and RH8 running in virtual machines for that very reason.

I agree that no one should be building with those libraries, but in fact people do use binaries already using them.

Bill Davidsen <davidsen tmr com>
  "We have more to fear from the bungling of the incompetent than from
the machinations of the wicked."  - from Slashdot

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]