[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: 54 GB in /var/log!!



On Sun, 26 Oct 2008 13:54:54 -0700, Craig White wrote:

> On Sun, 2008-10-26 at 20:12 +0000, Beartooth wrote:
	[....]
>> 	Obviously, I want to cut /var/log with electronic double-bitted
>> axes in both hands, to get to my user's GUI again; and to find the
>> source of the bloat and correct it.
>> 
>> 	What should I do first??
> ----
> from command line, cut down your large log files by locating them...
> 
> # find /var/log -type f -size +2000k -exec ls -lh {} \; | awk '{ print
> $8 ": " $5 }'

	I can't see for sure how many spaces, if any, there are between 
"print" and "$8"; but I can experiment.

	Meanwhile, however, I'm getting other troubles. One error message 
says "invalid argument + to size". 

	The man page is way beyond me to slog through in less than about 
six months; but I did find a + on it; so I tried using the other + key. 
No joy.

	I also get an error message saying "missing argument to -exec"
 
> and any file that is really large (i.e. /var/log/Xorg.0.log)
> 
> command line empty it...
> # > /var/log/Xorg.0.log
> 
> if startx only works as root, it sounds as if some permission isn't
> correct (possibly /etc/X11/xorg.conf is not 644, readable by all users).
> Of course if that were the issue, /var/log/Xorg.0.log would tell you
> that or if it were some other permissions issue, the problem would
> probably be listed in /var/log/messages

	I'm very weak on permissions; I can never remember the mnemonic 
for those numbers. but I'll try "cd /etc/X11" and then "ls -l" to see if 
that tells me anything either comprehensible or repeatable.

> On Fedora 9, it often is enough to just do something like # mv
> /etc/X11/xorg.conf /etc/X11/xorg.conf-bak # shutdown now -r
> 
> and it is automatically rebuilt upon reboot

	I tried that, and got only the dread "out of range" message. I'll 
try again with "system-config-display" and "system-config-display --
reconfig" It would be a great help to get X back for my user, if only to 
enable c&p between the CLI and Pan.

	Many thanks to all for the help so far!

-- 
Beartooth Staffwright, PhD, Neo-Redneck Linux Convert
Remember I know precious little of what I am talking about.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]