[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora 9 32 or 64 Bit - Which One?



Kevin Kofler wrote:
Kevin J. Cummings <cummings <at> kjchome.homeip.net> writes:
If you are willing to deal with the issues, then x86_64 is for you. If not, then stick with the i386 stuff.

What issues?

Issues, hassles, basically the same. The things that have to be worked around.

1) My lappie has an ATI Mobile Radeon X1600 video system. It worked on FC6 using the fglrx driver from livna. F9 upgraded Xorg to a version that fglrx does not yet support.

This has nothing whatsoever to do with x86_64, it's exactly the same on F9 i386.

It wasn't when I first upgraded. The first problem was that the API changed and i386 worked and x86_64 didn't. Over time, ATI fixed that problem (took a couple of months), but not the Xorg version problem.

2) Many firefox plugins require nspluginwrapper because there are no x86_64 versions for them (Adobe Flash, Adobe Reader). Getting it to work correctly is straightforward and the Fedora Project Documentation is correct if you follow it.

So what's the problem there?

Maybe not a problem, but a big hassle. And, it didn't use to be that way on i386.

Sometimes Flash just doesn't work until I restart firefox.  And the Acrobat
embedded reader can bring the laptop to its knees with some sort of memory
leak.  Its also not as fast going through the nspluginwrapper.

But nspluginwrapper is used by default even on 32-bit installations for security reasons (because running the plugin in a separate process allows confining it with SELinux).

Again, it didn't use to be that way.  Its a hassle.

Some people have configured their browsers to run acroread as an external
application directly (instead of the embedded reader) to get around this.

Or just don't use acroread at all, that's what Okular and Evince are for.

When you say "don't use X" and "X" is written by the people who defined it, you are basically saying that the standard definers don't know what they are doing.... Seems very strange. None of the replacements ever work as well as the original. At least for me. Its a hassle.

Konqueror can even embed Okular as a KPart if that's important to you.

I don't use Konqueror.

3) Sometimes sound gets screwed up in the browser (firefox). Even when using gecko-mediaplayer. Restarting the browser, or sometimes restarting the X session is necessary.

I don't think this is related to 64-bit either.

Maybe not, but I never noticed it until I upgraded to x86_64.

4) If you want to run vmware-server you might want to upgrade to the version 2.0 BETA which has an X86_64 RPM. (the version 1 version is i386 only). I had no trouble running the .i386 version of vmware-server with the appropriate compatibility libraries. Now I'm running the x86_64 BETA and it runs my 32-bit virtual machine just fine. You *MAY* need to find the latest version of vmware-anyanyupdate (or you may not) for vmware-server version 1.

So where's the problem?

Hassle!  Please stop changing the intent of my words!

5) Finding x86_64 versions of Firefox and Thunderbird ADDONs can be an adventure.

OK, this is one valid argument. But the addons most people actually use should be available for x86_64.

OK, so you're telling me I'm using the wrong addons?  B^)

So can finding addons that support firefox 3.0 in some cases.

This has nothing whatsoever to do with x86_64, it's exactly the same on F9 i386.

Maybe so, but its a hassle.

6) WINE is i386 only. I tried to get sound working in WINE and discovered that it wanted to drag in lots of i386 libraries, not all of which were compatible with all of the x86_64 versions I have installed (some from livna, some from atrpms, some from fedora). I gave up on the conflicts and continue to run wine without support for sound.

I don't know how you ended up with all those conflicts. You should not need anything not in Fedora to get sound in WINE working. "yum install alsa-plugins-pulseaudio.i386" should be enough, and that drags in only stuff from Fedora.

The problem is not with alsa-plugins-pulseaudio, its with jack-audio-connection-kit, needed by wine-jack.

7) FC6 used cubbi-suspend2 kernels in order to suspend and hiberate correctly. I was unable to make the tuxonice kernels work for me on F9, but the stock kernel support works fine with F9. (It may not be as fast as tuxonice, but it does suspend/hibernate and restore without any major problems.)

This has nothing whatsoever to do with x86_64, it's exactly the same on F9 i386.

Maybe so, bu I ran into it after I upgraded to x86_64.

8) My wireless is now much more reliable with F9, but that could be the new iwl3945 driver and not the old ipw3945 driver.

This is actually a good thing, not a problem. :-) In any case, it's not x86_64-specific either.

        Kevin Kofler

--
Kevin J. Cummings
kjchome rcn com
cummings kjchome homeip net
cummings kjc386 framingham ma us
Registered Linux User #1232 (http://counter.li.org)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]