[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora 9 32 or 64 Bit - Which One?



Kevin Kofler wrote:
Kevin J. Cummings <cummings <at> kjchome.homeip.net> writes:
What issues?
Issues, hassles, basically the same. The things that have to be worked around.

My question was: can you please list the actual issues, hassles or however you want to call them? Because most of what you listed is either:
* no hassle at all (like a single yum install line will solve your problem) or
* not an issue with x86_64: you upgraded from FC6 to F9 at the same time as your 32->64-bit migration. That's a big upgrade, skipping 2 releases even. So saying "this worked better on my old FC6 i386" is completely irrelevant for the question which started this thread, which is "should I go with F9 i386 or F9 x86_64?".

The OP asked for "any and all advice".  Please don't change the subject.

This has nothing whatsoever to do with x86_64, it's exactly the same on F9 i386.
It wasn't when I first upgraded. The first problem was that the API changed and i386 worked and x86_64 didn't. Over time, ATI fixed that problem (took a couple of months), but not the Xorg version problem.

Fglrx just plain didn't work on F9, be it 32-bit or 64-bit. They now have a beta out which should work, it's up at RPM Fusion for both i?86 and x86_64.

No, actually, there were 2 different problems. The first was an x86_64 only problem as a symbol was no longer exported by the x86_64 kernel that fglrx relied upon, but was still present in the i386 kernel.

The second problem was common to both i386 and x86_64.

Having 2 problems on x86_64 made it more difficult to diagnose and track down.

2) Many firefox plugins require nspluginwrapper because there are no x86_64 versions for them (Adobe Flash, Adobe Reader). Getting it to work correctly is straightforward and the Fedora Project Documentation is correct if you follow it.
So what's the problem there?
Maybe not a problem, but a big hassle. And, it didn't use to be that way on i386.

How is "yum install nspluginwrapper.i386" a hassle? It's one line!

Not for me, but just look at all of the question in this list alone for people asking why it doesn't work for them.

But nspluginwrapper is used by default even on 32-bit installations for security reasons (because running the plugin in a separate process allows confining it with SELinux).
Again, it didn't use to be that way.  Its a hassle.

But that's a change in Fedora 9 (actually it was in Fedora 7 or 8 already, but in any case it's like that in F9).

The OP was talking about a change from FC6 to F9, just like I had done.

Or just don't use acroread at all, that's what Okular and Evince are for.
When you say "don't use X" and "X" is written by the people who defined it, you are basically saying that the standard definers don't know what they are doing.... Seems very strange. None of the replacements ever work as well as the original. At least for me. Its a hassle.

The original is not Free Software, so of course it will cause more problems than the replacements which are.

Actually, the original reader is available for free download. Don't cloud the issue.

And if you believe the best software is always made by the people who defined a standard, stop using Firefox and use Amaya instead, it's from the W3C. :-D (FYI, don't bother, it's essentially useless as a browser. It may arguably have some use as a website editor, but even there there are better alternatives.)

PDF was designed (and released) by Adobe. Its their reader that doesn't have an x86_64 release, and therefore is the problem causing us to have to use nspluginwrapper. And the fact that you have to install *BOTH* versions of nspluginwrapper (.i386 and .x86_64) makes it even more confusing.

Konqueror can even embed Okular as a KPart if that's important to you.
I don't use Konqueror.

Your loss. ;-)

B^)

3) Sometimes sound gets screwed up in the browser (firefox). Even when using gecko-mediaplayer. Restarting the browser, or sometimes restarting the X session is necessary.
I don't think this is related to 64-bit either.
Maybe not, but I never noticed it until I upgraded to x86_64.

But that doesn't mean it is relevant for the i386 vs. x86_64 discussion.

Back to what the OP wanted, "any and all advice".

4) If you want to run vmware-server you might want to upgrade to the version 2.0 BETA which has an X86_64 RPM. (the version 1 version is i386 only). I had no trouble running the .i386 version of vmware-server with the appropriate compatibility libraries. Now I'm running the x86_64 BETA and it runs my 32-bit virtual machine just fine. You *MAY* need to find the latest version of vmware-anyanyupdate (or you may not) for vmware-server version 1.
So where's the problem?
Hassle!  Please stop changing the intent of my words!

How's running the latest version of your software a hassle?

Lack of available x86_64 is a hassle in my book. The latest copy is still a BETA (or was when I last downloaded it). Not everyone *wants* to run BETA software.

OK, this is one valid argument. But the addons most people actually use
should be available for x86_64.
OK, so you're telling me I'm using the wrong addons?  B^)

^^

So can finding addons that support firefox 3.0 in some cases.
This has nothing whatsoever to do with x86_64, it's exactly the same on F9 i386.
Maybe so, but its a hassle.

But that doesn't mean it is relevant for the i386 vs. x86_64 discussion.

Back to the OP's original request again....

The problem is not with alsa-plugins-pulseaudio, its with jack-audio-connection-kit, needed by wine-jack.

You don't need wine-jack to get sound in WINE. JACK is not the default sound server in Fedora, PulseAudio is.

Because of the way I upgraded from FC6, I'm not running PulseAudio....
Perhaps that *my* problem. I like to think that's Fedora's lack of proper upgrade path problem.

7) FC6 used cubbi-suspend2 kernels in order to suspend and hiberate correctly. I was unable to make the tuxonice kernels work for me on F9, but the stock kernel support works fine with F9. (It may not be as fast as tuxonice, but it does suspend/hibernate and restore without any major problems.)
This has nothing whatsoever to do with x86_64, it's exactly the same on F9 i386.
Maybe so, bu I ran into it after I upgraded to x86_64.

But that doesn't mean it is relevant for the i386 vs. x86_64 discussion. The fact that you happened to upgrade from FC6 to F9 at the same time is completely irrelevant here.

But, its what the OP wants to do.... So please explain why it is irrelevant?

        Kevin Kofler

Do you just like to argue? This is getting quite pointless now. If you wish, you can have the last word.

--
Kevin J. Cummings
kjchome rcn com
cummings kjchome homeip net
cummings kjc386 framingham ma us
Registered Linux User #1232 (http://counter.li.org)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]