[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: What is filesystem panic?



Mikkel L. Ellertson wrote:
Per Anton Rønning wrote:
I guess I should rephrase my question about my 4GB memory stick/pen,
where the filesystem
now is set to readonly when I enter it into one of the slots.
Could anyone tell me what might have happened by taking a look at the
snip of the logfile?

I am not allowed to do anyting but reading files. I am not allowed to
delete files ,remove directires
or write to files, even if I change to root privileges.
I cannot say when this started - it just happened one time when I tried
to backup some files to the Jet Flash.
Then I got the message (one example):
 cp: cannot create regular file `/media/disk/trade/statQ': Read-only
file system
Does anyone have a clue? I'd be grateful for pointers in the right
direction.

*** snip ***
Oct 27 11:36:30 localhost kernel: FAT: Filesystem panic (dev sdb1) [!!!!!!!! - my remark]
An error was found on the file system that will not allow it to
finish mounting it.

Oct 27 11:36:30 localhost kernel:    fat_free_clusters: deleting FAT
entry beyond EOF  [My remark: What does this mean? Looks like an
error message]
I am guessing, but it sounds like there were clusters assigned to a
file in the FAT, but were actually after the end of the file. Or
another way to say it is that the actual file length was much
shorter then the space assigned to it.

Oct 27 11:36:30 localhost kernel:    File system has been set read-only
[!!!!!!! - my remark]
*** end snip ***

There are errors in the file system that can not be automatically
fixed, so the file system is being mounted Read Only to prevent
further damage, while allowing you to recover what data you can.
If you have a Windows system, run disk check on it, and see what it
reports. You may also want to run fdisk on it under Linux, and see
what it says. You may have to backup and re-format the drive before
it will work correctly.

Mikkel
I have tried both fdisk and cfdisk, but non of these are allowed open the jetflash device
(as root!)
It has made itself inaccessible it seems, so I guess I just have to discard it. If there is no command that I have not thought of that might help me to erase its contents and
create everyting (i.e. some backup directories) anew.

BRGDS
PAR


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]