[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Command help?



Bradley wrote:
Patrick O'Callaghan wrote:
On Thu, 2008-09-25 at 14:24 -0700, Rick Stevens wrote:
Whoops!  In my previous comment on this, I neglected to mention you
really need to run /etc/rc.d/rc with the desired runlevel to force the
/etc/rc.d/rcX.d stuff to go.  In other words, if you do "telinit 3",
then you should also do "/etc/rc.d/rc 3" after it.
I don't think this is right. AFAIK the change in run level causes the
script to be run automatically. Note that on F9 the mechanism is
different from on previous Fedoras as it now uses the new upstart
system, but a quick look at /etc/event.d/rc3 shows an explicit call to
"exec /etc/rc.d/rc 3". (The OP doesn't mention which version of Fedora
he has but the new system is set up to emulate the old behaviour).

poc
Well, for all who are interested, I am running FC8 (haven't had time to
do a full system backup to prepare for FC9) and I have checked all all
of the K** and S** files are where they are suppose to be but telinit
doesn't run them all for some reason.  I have chosen to use run level 4
for the backups and it has all of the K** files but only two S** files
(the way I want it) but when I run telinit 4, it only "kills" two or so
and leaves the others running.

After your "telinit 4", have you tried "/etc/rc.d/rc 4"?

AFAIK, telinit does NOT fire up the /etc/rc.d stuff by itself and that's
how the K* and S* stuff get run.
----------------------------------------------------------------------
- Rick Stevens, Systems Engineer                      ricks nerd com -
- AIM/Skype: therps2        ICQ: 22643734            Yahoo: origrps2 -
-                                                                    -
-          Programmers often confuse Halloween and Christmas.        -
-              After all, 31 Oct is the same as 25 Dec!              -
----------------------------------------------------------------------


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]