[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Proftpd-user] Problem of installation



Dear All,

Just tried to install the new version of 1.3.1 ( rpm packages )...
But the test result is :

C:\>ftp 192.168.0.254
Connected to 192.168.0.254.
220 ProFTPD 1.3.1 Server (ProFTPD) [192.168.0.254]
User (192.168.0.254:(none)): manager
331 Password required for manager
Password:
530 Login incorrect.
Login failed.
ftp>

/var/log/messages:

Sep 28 17:22:49 svr1 xinetd[2154]: START: ftp pid=2160 from=::ffff:192.168.0.88
Sep 28 17:22:49 svr1 proftpd[2160]: warning: handling possibly truncated configuration data at line 40 of '/etc/proftpd.conf'
Sep 28 17:22:49 svr1 proftpd[2160]: svr1 (192.168.0.88[192.168.0.88]) - FTP session opened.
Sep 28 17:23:47 svr1 xinetd[2154]: EXIT: ftp status=0 pid=2160 duration=58(sec)
~

/etc/proftpd.conf :

ServerType    inetd
DefaultServer    on

UseReverseDNS    off
IdentLookups    off

Port    21

Umask    022

MaxInstances    30
MaxClients    50

User    nobody

TimeoutIdle 1800
TimeoutStalled 1800
TimeoutNoTransfer 1800
TimeoutLogin 1800
TimesGMT off

AllowRetrieveRestart on
AllowOverwrite on
AllowStoreRestart on

ServerIdent On "FTP Server"

# Only for user manager :

<Directory /*>
AllowOverwrite  on
    <Limit LOGIN CWD MKD RMD RNFR RNTO DELE STOR RETR READ SITE_CHMOD>
    AllowUser manager
    IgnoreHidden    on
    DenyAll
            </Limit>
</Directory>

User manager and edward :

<Anonymous /home/edward>
   User    edward
   Group    edward
   HideUser    manager
   AnonRequirePassword    yes
    <Directory /home/edward>
      AllowOverwrite    on
         <Limit LOGIN CWD MKD RMD RNFR RNTO DELE STOR RETR READ SITE_CHMOD>
             AllowUser    edward
        IgnoreHidden    on
        DenyAll
          </Limit>
    </Directory>
            
    <Directory /*>
            AllowOverwrite    off
    DenyAll
            </Directory>
</Anonymous>

Is any mistake about the config file ?

Thanks !

Edward.

Devrim G逴D鄇 wrote:
On Sat, 2008-09-27 at 13:11 +0800, edwardspl ita org mo wrote:
  
Mine is FC8 System...
So, which gcc packages must be installed before proftp 1.3.1
( tarball )
installed ?
    

Why don't you use Fedora repositories? Just checked, and Fedora 8 has
1.3.1 already.

Regards,
  

------------------------------------------------------------------------- This SF.Net email is sponsored by the Moblin Your Move Developer's challenge Build the coolest Linux based applications with Moblin SDK & win great prizes Grand prize is a trip for two to an Open Source event anywhere in the world http://moblin-contest.org/redirect.php?banner_id=100&url=""> __________ NOD32 3475 (20080926) Information __________ This message was checked by NOD32 antivirus system. http://www.nod32.com.hk

_______________________________________________ ProFTPD Users List <proftpd-users proftpd org> Unsubscribe problems? http://www.proftpd.org/list-unsub.html __________ NOD32 3475 (20080926) Information __________ This message was checked by NOD32 antivirus system. http://www.nod32.com.hk

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]