[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: python Q?



On 28Sep2008 07:20, Gene Heskett <gene heskett verizon net> wrote:
| Greetings all;
| 
| Recent yumex updates om an F8 system seem to have fouled up one or two things:
| 
| [root coyote ~]# /usr/bin/system-config-display
| Traceback (most recent call last):
|   File "/usr/share/system-config-display/xconf.py", line 315, in <module>
|     hardware_state = XF86HardwareState(xconfig)
|   File "/usr/lib/python2.5/site-packages/rhpxl/xhwstate.py", line 175, in 
| __init__
|     self.init_from_xconfig(xconfig)
|   File "/usr/lib/python2.5/site-packages/rhpxl/xhwstate.py", line 261, in 
| init_from_xconfig
|     if screen.device:
| AttributeError: 'NoneType' object has no attribute 'device'

I had this happen on an F9 system with two monitors running off a single
NVidia card. I took it to mean that the tool didn't cope with one card,
two monitors, and had made a structure for each monitor, and the second
structure had not had its card/device field initialised.

| Can this be fixed?
| If yes, how?

No idea, sorry. I gave up on system-config-display, flailed with "X
-configure" and an example config I found on the web.

What sort of setup are you trying to get going?
-- 
Cameron Simpson <cs zip com au> DoD#743
http://www.cskk.ezoshosting.com/cs/

Four lines good, eight lines bad.       - the signature farm


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]